Find the answer to your Linux question:
Results 1 to 5 of 5
wifiblues: my sys: a desktop Amd sempron2200 single core. i have Tp-link card with Atheros ar5212 chip 108m wireless .PCI add in card. Runs XP perfect. lspci shows it accurately. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    10

    wifi driver load fails, Centos +atheros 5212


    wifiblues:
    my sys: a desktop Amd sempron2200 single core.
    i have Tp-link card with Atheros ar5212 chip 108m wireless .PCI add in card. Runs XP perfect.
    lspci shows it accurately.
    Centos 5 Linux. ( no help at all their forum)


    no driver. so I followed the instructions on the centros page.


    HowTos/Laptops/Wireless - CentOS Wiki

    i get no errors. with all scripts run per above.
    I then look in the Configure RPMforge in yum followed by yum install madwifi.

    i look in the lib modules net dirs (every where) and there ares no driver for this chip .(scanning todays date) see Prism an others but not this one.
    so of course modprobe ath_pci would fail and does.


    advice?, should i just switch to suse 11 or should i follow the generic instructions on
    madwifi.org.

    anyone know a way to get centros happy with madwifi + ar5212?

    or ?

    thanks kindly for any leads , tips etc.


    jerry

    Ps. read hundreds of posts to learn how to get this card working. many Linux distro's too.

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    In my experience, CentOS does not have a lot of the common driver modules compiled into the kernel. Since it is meant mainly as a server distribution, I guess that things like wireless are supposedly not needed on a server.This makes it difficult to use some hardware.

    Have you tried enabling the CentOSPlus repository, and upgrading to that kernel? It may make things a little easier.

    AdditionalResources/Repositories - CentOS Wiki
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Sep 2008
    Posts
    10

    ahhhhhhhhhhhhh

    thanks Paul, very much.

    server. ok. ( yes, i have centos 4 on my apache running now)


    i printed out the whole Madwifi driver section at atrpms.net and could not
    figure out the 8 pages of drivers. until i noticed the plus and non plus.
    wow. (very complex with xen, pAE and then plus and non plus, wow)

    and of course wifi and a zillion others things only slow a server kernel.


    thanks again for your help.

    PS:
    if i re-Install using my Centos 5 DVD, can i select PLUS or something else more suited to a workstation or Laptop.
    EG: OS, Fire fox and wifi being the top features.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    CentOSPlus is simply a repository used for updating after you have CentOS installed. Updating the kernel using the CentOSPlus repository may be all you need.

    I have not tried WiFi on CentOS, so I don't know what will work. I did try to run MythTV, and found even the CentOSPlus kernel to be lacking. I could not compile the nVidia driver or the v4l-dvb drivers, and ended up downloading kernel sources from kernel.org. I compiled my own kernel, then everything worked great.

    A member of my local Linux Users Group told me he tried in vain to get his wireless working on CentOS. He gave up and installed Ubuntu, and it worked out-of-the-box.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #5
    Just Joined!
    Join Date
    Sep 2008
    Posts
    10
    thanks
    yes, and i did find the .config for the kernel and did look at it.
    C5.2 is missing most of the important wireless bits. crypto etc.

    im going to try suse 10.3 followed by 11 next.

    just need "out of the box" support, config after that is no big deal. (no wired connections, no searching for rpms, and compiling"
    WPA AES must be ready to work.

    yes, Ubantu, does work. so does Debian.

    just on the top OEM friendly Wifi chip makers.
    not too thrilled by ndiswrapper.

    btw , it Centros is fast. an amazing distro.....for sure.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •