Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, Actaully my system is not shutting down. I have tried all the possibilities with acpi and apm in Grub part after kernel but nothing happened. I also modified etc/modprobe.conf ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    1

    ShutDown Problem with linux(red hat)


    Hi,

    Actaully my system is not shutting down. I have tried all the possibilities with acpi and apm in Grub part after kernel but nothing happened. I also modified etc/modprobe.conf with apm power_off=1 but nothing happened.
    and then ultimately I tried etc/kde/kdm/kdmrc and then added terminateServer but then also my problem was not solved.

    ACPI is enabled I have chcked it out.

    PLZ help me out.

    It gives me error
    INIT:no process left in this runlevel

    Thanks a lot

  2. #2
    Linux Enthusiast
    Join Date
    Oct 2004
    Posts
    609
    What do you mean with "does not shut down"? What happens if you select "switch off" from the application menu?

    What happens if you, as root, use the command:
    Code:
    init 0

  3. #3
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I have a similar problem with a Debian based system, as it won't completely shut down when I tell it to.

    My solution was to use the terminal command "shutdown".
    Code:
    Usage:    shutdown [-akrhHPfnc] [-t secs] time [warning message]
                      -a:      use /etc/shutdown.allow
                      -k:      don't really shutdown, only warn.
                      -r:      reboot after shutdown.
                      -h:      halt after shutdown.
                      -P:      halt action is to turn off power.
                      -H:      halt action is to just halt.
                      -f:      do a 'fast' reboot (skip fsck).
                      -F:      Force fsck on reboot.
                      -n:      do not go through "init" but go down real fast.
                      -c:      cancel a running shutdown.
                      -t secs: delay between warning and kill signal.
                      ** the "time" argument is mandatory! (try "now") **
    What worked for me, was this command.
    Code:
    shutdown -h now
    You need to give your user shutdown privileges, through the file /etc/shutdown.allow. To do this, run these commands as root.
    Code:
    touch /etc/shutdown.allow
    Code:
    echo "userneme" >> /etc/shutdown allow
    Replace "username" with the login name of the user you want to allow, without the quotes.

    If this now works through a terminal, you can then make a script with this command in it. I put the script on my desktop, and I just click it to shutdown the computer. My script looks like this.
    Code:
    #!/bin/sh
    /sbin/shutdown -h now
    Make it executable with the chmod command, I named it "shutdown".
    Code:
    chmod +x shutdown
    It works real slick!
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •