Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
please can any one help me.I am a new user of linux and I have installed fedora8 on my system and i unable to play audio and vidio through any ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    8

    Red face audio vidio problem in fedora8


    please can any one help me.I am a new user of linux and I have installed fedora8 on my system and i unable to play audio and vidio through any player.

    i tried these steps:
    1. rpm -ivh http://rpm.livna.org/livna-release-7.rpm
    2. yum install gstreamer-plugins-uglu
    3. yum remove totem totem-mozplugin totem-plparser
    Setting up Remove Process
    4. yum install totem-xine totem-xine-mozplugin totem-xine-plparser libdvdcss libdvdnav libdvdplay xine-lib-extras-nonfree rhythmbox.i386 0:0.10.0-8.fc7
    it did not give me any result and it show the results --

    [root@localhost ~]# rpm -ivh http://rpm.livna.org/livna-release-7.rpm
    Retrieving http://rpm.livna.org/livna-release-7.rpm
    warning: /var/tmp/rpm-xfer.GKlByH: Header V3 DSA signature: NOKEY, key ID a109b1ec
    Preparing... ########################################### [100%]
    1:livna-release ########################################### [100%]

    [root@localhost ~]# yum install gstreamer-plugins-uglu
    livna 100% |=========================| 2.1 kB 00:00
    primary.sqlite.bz2 100% |=========================| 464 kB 00:05
    fedora 100% |=========================| 2.1 kB 00:00
    adobe-linux-i386 100% |=========================| 951 B 00:00
    updates 100% |=========================| 2.6 kB 00:00
    Setting up Install Process
    Parsing package install arguments
    No package gstreamer-plugins-uglu available.
    Nothing to do
    [root@localhost ~]# yum remove totem totem-mozplugin totem-plparser
    Setting up Remove Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package totem-plparser.i386 0:2.20.1-1.fc8 set to be erased
    --> Processing Dependency: libtotem-plparser.so.7 for package: rhythmbox
    ---> Package totem-mozplugin.i386 0:2.20.1-1.fc8 set to be erased
    ---> Package totem.i386 0:2.20.1-1.fc8 set to be erased
    --> Running transaction check
    ---> Package rhythmbox.i386 0:0.11.2-10.fc8 set to be erased
    --> Finished Dependency Resolution

    Dependencies Resolved

    ================================================== ===========================
    Package Arch Version Repository Size
    ================================================== ===========================
    Removing:
    totem i386 2.20.1-1.fc8 installed 5.2 M
    totem-mozplugin i386 2.20.1-1.fc8 installed 549 k
    totem-plparser i386 2.20.1-1.fc8 installed 69 k
    Removing for dependencies:
    rhythmbox i386 0.11.2-10.fc8 installed 9.0 M

    Transaction Summary
    ================================================== ===========================
    Install 0 Package(s)
    Update 0 Package(s)
    Remove 4 Package(s)

    Is this ok [y/N]: y
    Downloading Packages:
    Running rpm_check_debug
    Running Transaction Test
    Finished Transaction Test
    Transaction Test Succeeded
    Running Transaction
    Erasing : totem-plparser ######################### [1/4]
    Erasing : totem-mozplugin ######################### [2/4]
    Erasing : totem ######################### [3/4]
    Erasing : rhythmbox ######################### [4/4]

    Removed: totem.i386 0:2.20.1-1.fc8 totem-mozplugin.i386 0:2.20.1-1.fc8 totem-plparser.i386 0:2.20.1-1.fc8
    Dependency Removed: rhythmbox.i386 0:0.11.2-10.fc8
    Complete!
    [root@localhost ~]# yum install totem-xine totem-xine-mozplugin totem-xine-plparser libdvdcss libdvdnav libdvdplay xine-lib-extras-nonfree rhythmbox.i386 0:0.10.0-8.fc7
    Setting up Install Process
    Parsing package install arguments
    No package totem-xine-plparser available.
    No package libdvdnav available.
    No package 0:0.10.0-8.fc7 available.
    Resolving Dependencies
    --> Running transaction check
    ---> Package xine-lib-extras-nonfree.i386 0:1.1.15-1.lvn8 set to be updated
    --> Processing Dependency: libavutil.so.49 for package: xine-lib-extras-nonfree
    --> Processing Dependency: libvcdinfo.so.0 for package: xine-lib-extras-nonfree
    --> Processing Dependency: libpostproc.so.51 for package: xine-lib-extras-nonfree
    --> Processing Dependency: libavcodec.so.51 for package: xine-lib-extras-nonfree
    --> Processing Dependency: libdca.so.0 for package: xine-lib-extras-nonfree
    --> Processing Dependency: vcdimager >= 0.7.23 for package: xine-lib-extras-nonfree
    --> Processing Dependency: libvcdinfo.so.0(VCDINFO_0) for package: xine-lib-extras-nonfree
    --> Processing Dependency: libmad.so.0 for package: xine-lib-extras-nonfree
    --> Processing Dependency: xine-lib(plugin-abi) = 1.24 for package: xine-lib-extras-nonfree
    ---> Package rhythmbox.i386 0:0.11.2-10.fc8 set to be updated
    --> Processing Dependency: libtotem-plparser.so.7 for package: rhythmbox
    ---> Package libdvdcss.i386 0:1.2.9-4.lvn6 set to be updated
    ---> Package libdvdplay.i386 0:1.0.1-4.lvn6 set to be updated
    --> Processing Dependency: libdvdread.so.3 for package: libdvdplay
    ---> Package totem-xine.i386 0:2.20.1-1.lvn8 set to be updated
    ---> Package totem-xine-mozplugin.i386 0:2.20.1-1.lvn8 set to be updated
    --> Running transaction check
    ---> Package xine-lib-extras-nonfree.i386 0:1.1.15-1.lvn8 set to be updated
    --> Processing Dependency: xine-lib(plugin-abi) = 1.24 for package: xine-lib-extras-nonfree
    ---> Package vcdimager.i386 0:0.7.23-3.lvn6 set to be updated
    ---> Package libmad.i386 0:0.15.1b-6.lvn8 set to be updated
    ---> Package libdca.i386 0:0.0.5-2.lvn8 set to be updated
    ---> Package totem-plparser.i386 0:2.20.1-1.fc8 set to be updated
    ---> Package ffmpeg-libs.i386 0:0.4.9-0.42.20071121.lvn8 set to be updated
    --> Processing Dependency: libfaac.so.0 for package: ffmpeg-libs
    --> Processing Dependency: libx264.so.56 for package: ffmpeg-libs
    --> Processing Dependency: libfaad.so.0 for package: ffmpeg-libs
    --> Processing Dependency: faad2 = 1:2.0 for package: ffmpeg-libs
    --> Processing Dependency: libxvidcore.so.4 for package: ffmpeg-libs
    --> Processing Dependency: libmp3lame.so.0 for package: ffmpeg-libs
    --> Processing Dependency: liba52.so.0 for package: ffmpeg-libs
    ---> Package libdvdread.i386 0:0.9.7-3.fc8 set to be updated
    --> Running transaction check
    ---> Package xine-lib-extras-nonfree.i386 0:1.1.15-1.lvn8 set to be updated
    --> Processing Dependency: xine-lib(plugin-abi) = 1.24 for package: xine-lib-extras-nonfree
    ---> Package faad2.i386 1:2.0-21.20050131.lvn8 set to be updated
    ---> Package xvidcore.i386 0:1.1.3-1.lvn8 set to be updated
    ---> Package x264.i386 0:0-0.10.20070819.lvn8 set to be updated
    ---> Package a52dec.i386 0:0.7.4-11.lvn8 set to be updated
    ---> Package lame-libs.i386 0:3.97-6.lvn8 set to be updated
    ---> Package faac.i386 0:1.25-4.lvn8 set to be updated
    --> Processing Dependency: libmp4v2.so.0 for package: faac
    --> Running transaction check
    ---> Package xine-lib-extras-nonfree.i386 0:1.1.15-1.lvn8 set to be updated
    --> Processing Dependency: xine-lib(plugin-abi) = 1.24 for package: xine-lib-extras-nonfree
    ---> Package libmp4v2.i386 0:1.5.0.1-5.fc8 set to be updated
    --> Finished Dependency Resolution
    Error: Missing Dependency: xine-lib(plugin-abi) = 1.24 is needed by package xine-lib-extras-nonfree
    [root@localhost ~]#

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Hi pin2, Welcome to the forums.
    I see that you have a typo,
    yum install gstreamer-plugins-uglu
    Should be
    yum install gstreamer-plugins-ugly
    Check this link for more info on installing a lot of different packages with Fedora 8.
    Good Luck.
    Fedora 8 Tips & Tricks
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    Sep 2008
    Posts
    8
    hi Mike thank you for reply.
    now i can able to play audio songs through movie player
    but i unable to play dvd or vcd on this player.When i starting movi player and choosing open location and type dvd://
    it showing an error and giving message----
    an error occured
    the playback of this movie requres advd sourceplugin which is not installed.
    please kindly reply me in detail.

  4. #4
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    You probably need to install libdvdcss, use yum to look for that.
    yum -s libdvdcss
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  5. #5
    Just Joined!
    Join Date
    Sep 2008
    Posts
    8
    hi Mike i installed libdvdcss,libdvdnav and insert my dvd
    now Movie player is autometically get started and again show
    a message Totem cann't play this tupe of media (dvd)
    because it does not have appropriate plugins to be able to read from the disk.
    .what is this command yum -s libdvdcss for?
    again when i want to install totem-xine it show
    totem-xine is conflicting with totem

  6. #6
    Just Joined!
    Join Date
    Sep 2008
    Location
    Madison, MS
    Posts
    8
    sometimes totem is wierd and stays running in the background try rebooting dont open totem until you install totem-xine....
    yum -s libdvdcss searches for packages based on your query after the "-s" (search)
    you could also use:

    yum search libdvdcss

    or even pipe it through grep for a more narrow search:

    yum search libdvdcss | grep "somestring"

    dont put in the quotes with the grep command unless its two separate words (you cant use a space in package names though)

  7. #7
    Just Joined!
    Join Date
    Sep 2008
    Posts
    8
    hi podmod
    i tried that yum search libdvdcss but it show 3 errors

    Could not retrieve mirrorlist http://rpm.livna.org/mirrorlist-development error was
    [Errno 14] HTTP Error 404: Not Found

    Could not retrieve mirrorlist http://rpm.livna.org/mirrorlist-7 error was
    [Errno 14] HTTP Error 404: Not Found

    Could not retrieve mirrorlist http://rpm.livna.org/mirrorlist-testing-6 error was
    [Errno 14] HTTP Error 404: Not Found


    After that it shows Matched: libdvdcss ===========
    libdvdcss.i386 : A library for transparent DVD device access with on-the-fly CSS
    : decryption.
    libdvdcss-debuginfo.i386 : Debug information for package libdvdcss
    libdvdcss-devel.i386 : Development files for the libdvdcss.


    after this when i tried to install totem-xine it shows me the upper three errors in between installation and at last showing these errors
    Error: totem-xine-mozplugin conflicts with totem-mozplugin
    Error: Missing Dependency: libc.so.6(GLIBC_2. is needed by package xine-lib-extras-nonfree-1.1.15-1.lvn10.i386 (livna-development)
    Error: totem-xine-mozplugin conflicts with totem
    Error: totem-xine conflicts with totem

  8. #8
    Just Joined!
    Join Date
    Sep 2008
    Location
    Madison, MS
    Posts
    8
    first off those three mirrors are probably old or incorrect because giving you the 404 error.... this means you need to update your repositories for yum i'm not at my linux box right now but type:

    man yum

    look through it and see if you can find the argument to update the repositories

    second try uninstalling totem and totem-mozplugin and then install totem-xine because it obviously doesn't like totem. post what happens and we'll go from there...

    third you must need to do a yum search for those missing dependencies or find and rpm off a site and download it go to the directory and type:

    rpm --aid -ivh <nameofpackage>

    that should automatically install dependencies for the dependency of totem (libc.so.6)

    please excuse the dependency hell

  9. #9
    Just Joined!
    Join Date
    Sep 2008
    Posts
    8
    I am unable to find the argument to update the repositories through
    man yum command
    please help me out breafly what to do.

  10. #10
    Just Joined!
    Join Date
    Sep 2008
    Location
    Madison, MS
    Posts
    8
    try to run this and then try to play a dvd...

    yum install libdvdread3
    yum install gxine

    i couldn't find libdvdcss either but i did find those two and
    the description states that it is the library for reading
    dvd's and gxine is a gtk+ interface for playing dvd's so i
    figure its worth the shot...
    tell me how it goes!!

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •