Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Using Fedora 9 x86_64, and connect to the internet with ethernet using onboard LAN. Every time I start Fedora up, the network manager can't connect/activate the onboard ethernet, and basically ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Mar 2008
    Posts
    100

    Internet doesn't reconnect on startup


    Using Fedora 9 x86_64, and connect to the internet with ethernet using onboard LAN.
    Every time I start Fedora up, the network manager can't connect/activate the onboard ethernet, and basically the only way I could figure out how to get connected was to delete all my active connections then reboot and let Fedora detect it automatically. That got old, so I put in an old network card I had laying around and connected using that. Problem is, the connection through the card is ungodly slow (10 MB/s), so I removed it and now I'm back to square one.
    I've tried simply creating a new ethernet connection using the onboard LAN via Network Manager, but I still have this problem...any ideas on how to get Fedora to recognize and connect to the onboard on startup?
    Thank you in advance.

  2. #2
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Does Fedora detect it on boot? Or does it just not connect? And if it's detected, is it set in Network Manager to activate on boot?
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  3. #3
    Linux Newbie
    Join Date
    Mar 2008
    Posts
    100
    Yep, during start up, it does detect the onboard LAN, and tries to activate it.
    After about a minute, it pings the LAN, and the ping fails.

    It is set in Network Manager to activate on start up.

  4. $spacer_open
    $spacer_close
  5. #4
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Execute
    Code:
    cat /etc/rd.d/init.d/network
    Post output here.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  6. #5
    Linux Newbie
    Join Date
    Mar 2008
    Posts
    100
    It says "no such file or directory."

  7. #6
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Hhmmm... Give me a few on that. I'm at work right now, so let me check my Fedora install for the exact file we need to look for.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  8. #7
    Linux Newbie
    Join Date
    Mar 2008
    Posts
    100
    no problem...I'm just glad to get help with this, I'm stumped!

  9. #8
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Try this... execute
    Code:
    system-config-network
    and disable 'Network Manager'. This might explain why I've never had a problem with my NIC activating. Let me know what happens.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  10. #9
    Linux Newbie
    Join Date
    Mar 2008
    Posts
    100
    Ok, heres where I'm at now....
    After doing what you suggested above and rebooting, Firefox initially started up in Work Offline mode. After switching back to Online Mode, I was able to connect to the internet.

    The icon for Network manager has the red X on it, indicating no connection, but the Network Configuration shows it is active now. What is strange is that Network Manager seems to have re-enabled itself, because the checkbox "Enable Networking" is checked (but says that device is unmanaged).
    Either way, I'm on the internet now without having to go through the 'deleting-all-connections-then-rebooting' ritual. Now, the only thing is is that the internet is running quite a bit slower than it does when I'm using Vista (but it is still running faster than when I had the old NIC plugged in).
    Do you have any suggestions on how to speed it up a bit? Thank you for your help!

  11. #10
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Do you happen to have SELinux running? I know it's a security feature, but it slowed down my whole rig until I turned it off. Also, if you have your box set for automatic updates, turn that off, too. Let's see if we get any results from that!
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •