Find the answer to your Linux question:
Results 1 to 6 of 6
I installed Fedora8 in a virtual machine using VirtualPC on MacOSX tiger. I know, Virtual Box and Parallels is better, but they don't run on the PPC platform. I'm not ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    73

    How to force console mode @ boot


    I installed Fedora8 in a virtual machine using VirtualPC on MacOSX tiger.
    I know, Virtual Box and Parallels is better, but they don't run on the PPC platform.

    I'm not familiar with Fedora at all.
    After the install finished, and it came time for 1st boot, Grub boots the OS fine but it tries to boot directly into X and gives me a garbled screen.
    That's as far as it goes.

    I'm used to Slackware, which boots in console mode and then you run X manually.
    Which is what I want Fedora to do so I can go in and configure X manually.
    However, the command line that's invoked by hitting 'c' on the Grub boot screen isn't actually a shell prompt.
    So very few commands can be used.

    What I would like to know is how to force Fedora to boot into a shell prompt with no GUI.

  2. #2
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    All you need to do is edit the /etc/inittab file to runlevel 3. So change
    Code:
    id:5:initdefault:
    to
    Code:
    id:3:initdefault:
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  3. #3
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    Quote Originally Posted by jayd512 View Post
    All you need to do is edit the /etc/inittab file to runlevel 3. So change
    Code:
    id:5:initdefault:
    to
    Code:
    id:3:initdefault:
    This will boot to console every time ... if you are struggling to get to boot to console to change the config file or setup X then at the grub menu press escape to exit the menu, select Linux option and press e to edit, then select the kernel line and add a space and 3 to the end, then press enter and b to boot ... that should start in runlevel 3. You may also be able to get to a console from a normal boot pressing ctrl+alt+f1 so you can fix the issue, and ctrl+alt+backspace may stop the X server and drop you at a command prompt.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2008
    Posts
    73
    That is the problem.
    I can't get to a command prompt to edit the inittab because none of the usual commands are working to prevent fedora from attempting to boot into the GUI.

  6. #5
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Quote Originally Posted by glaston View Post
    That is the problem.
    I can't get to a command prompt to edit the inittab because none of the usual commands are working to prevent fedora from attempting to boot into the GUI.
    You can press the "e'' key when the GRUB menu displays to edit the kernel boot parameters.

    Just select the kernel line for the kernel you want to boot. Go to the end of that line and type "single" as a separate word, then press ENTER to exit the edit mode. Once back at the GRUB screen, press "b" to boot into single user mode. Edit the inittab file as needed, save, and reboot.

    Edit: oops, I missed that this is in virtual machine, so not sure if that might change things.
    Last edited by oz; 10-07-2008 at 06:02 PM.
    oz

  7. #6
    Just Joined!
    Join Date
    Sep 2008
    Posts
    73
    That's not working either.

    I don't understand it.

    These are the exact methods I used to get Debian running in a VM.

    Hitting ctrl-alt-f1 dropped me into a command prompt where I ran dpkgtool reconfigure xserver-xorg.
    Then switched the module from S3 to VESA, and dropped the bit depth to 16 because VPC doesn't play well in 24bit mode.

    With Fedora none of the kernel commands I issue make any difference.
    It drops me into a garbled screen everytime.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •