Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
When compiling anything, you usually do everything up to make install as a regular user. You then use su to give you root privileges to run make install ....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593

    When compiling anything, you usually do everything up to make install as a regular user. You then use su to give you root privileges to run make install.
    Please do not send Private Messages to me with requests for help. I will not reply.

  2. #12
    Just Joined! Test For Echo's Avatar
    Join Date
    May 2008
    Location
    Israel
    Posts
    38

    Thumbs up solved! here is the story

    first, you were right , the problem was glibc-header.

    i encountered difficulty with fedora repo:
    [root@localhost madwifi-hal-0.10.5.6-r3861-20080903]# yum install glibc-headers.i386
    Loaded plugins: fastestmirror, fedorakmod, protectbase, refresh-packagekit
    Loading mirror speeds from cached hostfile
    * livna: ftp-stud.fht-esslingen.de
    * fedora: ftp.iasi.roedu.net
    * freshrpms: ayo.ie.freshrpms.net
    * livna-source: ftp-stud.fht-esslingen.de
    * fedora-source: ftp.iasi.roedu.net
    * livna-testing: ftp-stud.fht-esslingen.de
    * updates: ftp.uni-erlangen.de
    67 packages excluded due to repository protections
    Setting up Install Process
    Parsing package install arguments
    Resolving Dependencies
    --> Running transaction check
    ---> Package glibc-headers.i386 0:2.8-3 set to be updated
    --> Processing Dependency: glibc = 2.8-3 for package: glibc-headers
    --> Running transaction check
    ---> Package glibc.i386 0:2.8-3 set to be updated
    --> Processing Dependency: glibc-common = 2.8-3 for package: glibc
    --> Finished Dependency Resolution
    glibc-2.8-3.i386 from fedora has depsolving problems
    --> Missing Dependency: glibc-common = 2.8-3 is needed by package glibc-2.8-3.i386 (fedora)
    Error: Missing Dependency: glibc-common = 2.8-3 is needed by package glibc-2.8-3.i386 (fedora)
    [root@localhost madwifi-hal-0.10.5.6-r3861-20080903]# yum install glibc-headers.i686
    Loaded plugins: fastestmirror, fedorakmod, protectbase, refresh-packagekit
    Loading mirror speeds from cached hostfile
    * livna: ftp-stud.fht-esslingen.de
    * fedora: ftp.iasi.roedu.net
    * freshrpms: ayo.ie.freshrpms.net
    * livna-source: ftp-stud.fht-esslingen.de
    * fedora-source: ftp.iasi.roedu.net
    * livna-testing: ftp-stud.fht-esslingen.de
    * updates: ftp.uni-erlangen.de
    67 packages excluded due to repository protections
    Setting up Install Process
    Parsing package install arguments
    No package glibc-headers.i686 available.
    Nothing to do
    so i disabled the fedora repo and added rawhide.
    then updated the glibc to a newer version and tried to compile madwifi again.

    this time it worked!




    thank you very very much for your help.
    all thumbs up!

  3. #13
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Let's hope that this driver will work better. Just follow the same How-To for setup of the card and driver. Let us know how it works out.
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. #14
    Just Joined! Test For Echo's Avatar
    Join Date
    May 2008
    Location
    Israel
    Posts
    38
    well, after compiling i just did modprobe ath_pci, and vuala. up and running, no reboot.

    ive also checked modprobe.conf aliased just right and that ath5k is blacklisted


    BTW, why u need to do "make" with regular user and "make install" as root?

  5. #15

  6. #16
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Hmm..

    This thread was closed and locked, I had to use my supreme powers to unlock it so that I could post a reply.

    One reason for not compiling programs as root, is that the files are then owned by root. You can't then do anything with them, unless you are root.
    Please do not send Private Messages to me with requests for help. I will not reply.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •