Ok, I have spent half the day trying to figure out what is going on, but I'm finally giving up and asking for help.

I have created a samba share on a RHEL4 server.
I can connect to the share from a Windows XP Pro box, I can view the files in the folder, but I can't open, create, rename, or delete files. The only thing I can do is Copy files into the folder. The folder is owned by the user I'm connecting with. I have no other samba shares on this server.

Here is the directory listing.

drwxrw-rw- 2 vmuser vmuser 4096 Oct 15 10:09 vtest

The smb.conf share looks like this right now, but I have tried many desperate attempts....

[vtest]
path = /vtest
valid users = vmuser
writable = yes
create mask = 766

I have tried a multitude of things, even so far as to create samba root user and connect with that, still the same results.

smbstatus displays this:

Samba version 3.0.23c-2.el5.2.0.2
PID Username Group Machine
-------------------------------------------------------------------
16364 vmuser vmuser media (xx.xxx.xxx.xxx)

Service pid machine Connected at
-------------------------------------------------------
vtest 16364 media Wed Oct 15 09:46:39 2008

No locked files


Any ideas or suggestions? Thanks in advance!