Find the answer to your Linux question:
Results 1 to 4 of 4
First I'll give my system specs: p4 2.6c MSI 865PE Neo-2(FISR) 512Mb (2x256) PC4000 OCZ Dual Channel Gold kit Geforece 6800GT 256Mb Maxtor 160Gb SATA drive (XP Installed here all ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    2

    Looping "Disabling IRQ #10" Problem


    First I'll give my system specs:

    p4 2.6c
    MSI 865PE Neo-2(FISR)
    512Mb (2x256) PC4000 OCZ Dual Channel Gold kit
    Geforece 6800GT 256Mb
    Maxtor 160Gb SATA drive (XP Installed here all NTFS)
    Maxtor 160Gb IDE drive (FC2 Installed on this drive0
    Samsung CDRW
    Samsung DVDR
    WinXP Pro SP2


    When I try to boot Fedora it takes around 10 minutes to boot. The main problem seems to be a looping "Disabling IRQ #10" error which loops over and over. Periodally another part of fedora will load then it's back to the looping. I've disabled ACPI and APIC in both the bios and by editing the kernel command in GRUB using "acpi=off noapic" at the end of the kernel command. This hasn't help. I've disabled my onboard networking/sound/usb and legacy controllers and I still get the same error. Does anyone have a clue why this is happening?!? Once fedora loads it seems to be ok but loading the OS and shutting it down takes far too long for it to be usable. If anyone has a clue what the problem is, the help would be greatly appreciated. (I've tried updating the kernel to 2.6.8-1.521 and it made no difference)

    Edit: I Know in windows the resource using irq 10 is:
    "Intel 82801EB SMBus Controller"

  2. #2
    Just Joined!
    Join Date
    Sep 2004
    Posts
    2

    Got it fixed!

    Was due to the SATA drive. I went into the BIOS and did the following:

    1) Went into "On-Chip IDE Configuration" menu.
    2) Set "On-Chip ATA Operate Mode" to "Legacy"
    3) Set "ATA Configuration" to "P-ATA Only"
    4) Set "S-ATA Keep Enabled" to "Yes"
    5) "P-ATA Keep Enabled Option" was greyed out
    6) Set "P-ATA Channel Selection" to "Both"
    7) "Combined Mode Operation" was greyed otu
    Set "S-ATA Ports Definition" to "P0-3rd./P1-4th"
    9) Set "Configure S-ATA as RAID" to "No"

    After that, Fedora loads within a minute and runs fine.

  3. #3
    Just Joined!
    Join Date
    Sep 2004
    Posts
    6
    I have nearly identical specs
    p4 3.0
    MSI 865PE Neo-2(FISR)
    1Gb (2x512)
    ATI Radeon 128 MB
    2 X Maxtor 120Gb SATA drive (XP Installed here all NTFS on one)
    WD 80Gb IDE drive (FC2 Installed on this drive0 )
    DVD-RW

    I was getting the same repeating error of a looping Disabling IRQ #10.

    I tried to change the BIOS as you tried and restarted booting to the FC2
    I got a message " NTLRD Missing Hit Alt-Ctrl-Del"
    This repeated so I went back to Bios to change back to the previous setting but found that the WD 80GB had dissapeared! Booted into windows and sure enough no IDE WD 80 GB????

    Did it just happen to die at the time? Or was it the BIOS setting change? Rebooted several time but it is GONE! I'll take it apart and unplug-boot-reattache and see what happens?
    Any thoughts?
    So far I have had no luck installing RedHat 8, FC1, FC2, and Debian on the MSI. I do have success running Knoppix from a CD...

  4. #4
    Just Joined!
    Join Date
    Sep 2004
    Posts
    3
    Skipjack, I used to have that same mobo and had trouble getting it to recognize both SATA and PATA drives at the same time. I finally did, using the IDE config in BIOS. I wish I could remember exactly what I did so I could tell you. In your case, try resetting the BIOS to what it was before you started tweaking (assuming your memory is better than mine!) You may even have to try installing the harddrives over again, one at a time. That or use a partition manager to change the drive letters back the way you want them.

    I'm having a similar IRQ loop trying to boot Mandrake 10, only in my case it's IRQ 18. My BIOS doesn't even show an IRQ 18!

    BTW, the reason I don't have the MSI anymore is because it was not seeing the northbridge temperature or fan speed. No big deal really, but 6 emails and 3 phone calls to their tech support got me exacly ONE response, in which the responder totally misunderstood my problem. So, back it goes...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •