Find the answer to your Linux question:
Results 1 to 6 of 6
hi friends, can anyone please help me on how to build BDM driver on Fedora Core 9. THanks NAndish...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2008
    Posts
    3

    BDM Driver installation on fedora core 9


    hi friends,
    can anyone please help me on how to build BDM driver on Fedora Core 9.

    THanks
    NAndish

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    If you are referring to the Developement tools and drivers for Motorola Background Debug Module (BDM) interface, found here.
    SourceForge.net: BDM tools

    There are instructions in the downloaded files. Open the README file in the m68k folder. I found these instructions had to be modified to suit your driver version number, and where you downloaded and extracted it.

    To make it easier, download and extract it to the top of your /home directory.
    Code:
    tar xzf m68k-bdm-1.4-pre4.tar.gz
    Now, create a folder to build the driver in, and enter it.
    Code:
    mkdir ~/build
    cd build
    You now must run the configure script that is in the m68k folder.
    Code:
    ~/m68k-bdm-1.4-pre4/m68k/configure
    If you dont get any errors, then run these commands.
    Code:
    make
    su
    make install
    I got an error in the configure stage.
    Code:
    checking for usb_init in -lusb... no
    configure: error: Could not find libusb. Try --with-libusb-dir.
    I found libusb:
    Code:
    $ locate libusb
    /usr/lib/libusb-0.1.so.4
    /usr/lib/libusb-0.1.so.4.4.4
    So I tried this command.
    Code:
    $ ~/m68k-bdm-1.4-pre4/m68k/configure --with-/usr/lib/libusb-0.1.so.4
    configure: error: invalid package name: /usr/lib/libusb-0.1.so.4
    That's as far as I could get. I hope that You don't get any errors, it makes things so much easier.
    Last edited by waterhead; 10-22-2008 at 12:53 AM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    I found that I was missing the libusb-devel package.
    Code:
    yum install libusb-devel
    I was then able to run configure, make and make install.
    Please do not send Private Messages to me with requests for help. I will not reply.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2008
    Posts
    3
    hi,
    i have m68k-gdb-bdm-6.3. in this directory i have m68k-bdm-1.3.1/driver/linux-2.6.
    in this directory i have bdm.c file and makefile. I am not getting how to install the driver. I have built my kernel source. is there any need to link the driver to the newly built source?

    Thanks
    Nandish

  6. #5
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    Where did you get that version from? The Sourceforge versions, that are available from the link in my first post, are 1.4.0, 1.3.0, 1.2.0 etc.

    The 1.3.0 version is from 2004, rather old. There is a configure script in the main folder of the files. Try running the configure command pointing to that folder instead of the m68k folder.
    Please do not send Private Messages to me with requests for help. I will not reply.

  7. #6
    Just Joined!
    Join Date
    Oct 2008
    Posts
    3
    hi,
    I have built the kernel, installed BDM driver and generated clf file for flash too. but when i run
    ./clf
    there is an error stating
    could not open /dev/bdmcf0
    what is this? Can anyone help me out?

    NAndish

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •