i am trying to cross compile pango-1.22.0 for arm on a fedora system .while i do ./configure i get the following error

errors :
1) ./configure --host=i686-linux --build=arm-linux
.....
........
checking Carbon/Carbon.h usability... no
checking Carbon/Carbon.h presence... no
checking for Carbon/Carbon.h... no
checking for CAIRO... no
no
checking for GLIB... no
configure: error:
*** Glib 2.17.3 or better is required. The latest version of
*** Glib is always available from ftp://ftp.gtk.org/.

2) the config.log contents

.........
.................
configure:23269: checking for GLIB
configure:23276: $PKG_CONFIG --exists --print-errors "$GLIB_MODULES"
Requested 'glib-2.0 >= 2.17.3' but version of GLib is 2.12.11
configure:23279: $? = 1
configure:23292: $PKG_CONFIG --exists --print-errors "$GLIB_MODULES"
Requested 'glib-2.0 >= 2.17.3' but version of GLib is 2.12.11
configure:23295: $? = 1
Requested 'glib-2.0 >= 2.17.3' but version of GLib is 2.12.11
configure:23322: result: no
configure:23326: error:
*** Glib 2.17.3 or better is required. The latest version of
*** Glib is always available from ftp://ftp.gtk.org/.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=arm-unknown-linux-gnu
ac_cv_c_compiler_gnu=yes
ac_cv_cxx_compiler_gnu=yes
ac_cv_env_CAIRO_CFLAGS_set=
ac_cv_env_CAIRO_CFLAGS_value=
............
............

could anyone help me solve this problem .i am totally new to this stuff . i dont have the least idea as to how i can link glib-2.17.3 to pango while configuring . i have the glib-2.17.3 cross compiled already in my /root .

i would like to get help since only after this can i compile the gtk and finally the mozilla porting . thanks in advance