Find the answer to your Linux question:
Results 1 to 4 of 4
Hi Every one!! I am trying to install an rpm a.b.c and getting following error: /etc/security/selinux/file_contexts: No such file or directory error: Failed dependencies: x.y.z is required by a.b.c When ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    2

    Error installing rpms


    Hi Every one!!

    I am trying to install an rpm a.b.c and getting following error:
    /etc/security/selinux/file_contexts: No such file or directory
    error: Failed dependencies:
    x.y.z is required by a.b.c

    When I install x.y.z I get the following error
    /etc/security/selinux/file_contexts: No such file or directory
    error: can't create transaction lock

    It wont allow me to create /etc/sec…. Directory
    I have tried changing permissions to maximum on rpm but it still doesn’t work.
    Any help to solve this problem asap will be great. I am new to this enviroment, dont know if it is the right place to ask this question or not.

    Regards

  2. #2
    Just Joined!
    Join Date
    Sep 2004
    Posts
    28
    you may not have permissions to this directory

    /etc/security/selinux/

    try with the root account.

  3. #3
    Just Joined!
    Join Date
    Sep 2004
    Posts
    2
    Thanx bulldozer I really appreciate your help.

    I have tried it with root but it I cant still see the specified directory/file.

    Also after trying with root privilege, i can see that the dependency error I am getting while tryin to install the first rpm is for an older version. Because when I try to install the rpm asked in the dependency, it shows me conflict saying that an updated version is already installed.

    "package libpcap-0.8.3-3 (which is newer than libpcap-0.7.2-7.9.1.1) is already installed"

    Any ideas?

  4. #4
    Linux Enthusiast Opnosforatou's Avatar
    Join Date
    Dec 2003
    Location
    Vleuten, The Netherlands
    Posts
    552
    If you want to force an extra installation of older libaries use the --force option.

    For info on how to install RPMS check here: http://www.linuxforums.org/forum/topic-21687.html
    ---[ MS09-99896 - Vulnerability in All MS Windows OS ; Using Windows Could Allow Remote Code Execution. ]---
    Hardware: Asus P4P800, 1GB, P4-3Ghz, Asus V9950, Maxtor ATA HD\'s, 3Com GBit lan, Audigy ZS Plat.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •