Find the answer to your Linux question:
Results 1 to 5 of 5
Firstly, I cant mount cdroms. mount /mnt/cdrom OR mount /dev/cdrom /mnt/cdrom gives "not a valid block device". The cdrom is fine, it works in win and used 2 work a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Location
    India
    Posts
    46

    Mounting cdroms & Sound Problems


    Firstly, I cant mount cdroms.
    mount /mnt/cdrom OR mount /dev/cdrom /mnt/cdrom
    gives "not a valid block device".
    The cdrom is fine, it works in win and used 2 work a few days ago. I dont know what i did. Actually, I think it stopped working when i upgraded to fc2 from redhat 9 last week Or maybe it is a direct consequence of playing with a lot of system services (do I need any enabled ?)

    Secondly, The sound is gone crazy. Xmms plays music files in short bursts (as the visualisation scope shows) but i can hear no sound at all. I use arts (alsa doesn't detect my onboard ac97 sound card).

    The problems r very weird but if u need more info ask.
    Any help is appreciated.

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Well...first off, arts is the KDE sound daemon, NOT a driver. So you either use ALSA or OSS (Open Sound System). OSS is deprecated, so I'll suggest that you migrate to ALSA (which is easier to configure anyway) if you're not using it already.

    Post the output of these commands:

    Code:
    lsmod
    lspci
    uname -a
    Back to the cdrom thing...

    Code:
    ls -al /dev | grep cdrom
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Location
    India
    Posts
    46
    # lsmod

    Module Size Used by
    ppp_deflate 4096 2
    zlib_deflate 19480 1 ppp_deflate
    ppp_async 8064 1
    ppp_generic 20500 6 ppp_deflate,ppp_async
    slhc 5632 1 ppp_generic
    udf 78596 0
    snd_intel8x0 26280 3
    snd_ac97_codec 50436 1 snd_intel8x0
    snd_pcm 68872 1 snd_intel8x0
    snd_timer 17156 1 snd_pcm
    snd_page_alloc 7940 2 snd_intel8x0,snd_pcm
    gameport 3328 1 snd_intel8x0
    snd_mpu401_uart 4864 1 snd_intel8x0
    snd_rawmidi 17184 1 snd_mpu401_uart
    snd_seq_device 6152 1 snd_rawmidi
    snd_mixer_oss 13824 1
    snd 38372 12 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_ mpu401_uart,snd_rawmidi,snd_seq_device,snd_mixer_o ss
    soundcore 6112 2 snd
    i810 52400 2
    ipv6 184288 8
    iptable_filter 2048 0
    ip_tables 13440 1 iptable_filter
    nls_utf8 1536 4
    nls_cp437 5376 4
    vfat 10496 4
    fat 33472 1 vfat
    dm_mod 33184 0
    uhci_hcd 23708 0
    ext3 102376 2
    jbd 40216 1 ext3

    # lspci
    00:00.0 Host bridge: Intel Corp. 82810 GMCH [Graphics Memory Controller Hub] (rev 03)
    00:01.0 VGA compatible controller: Intel Corp. 82810 CGC [Chipset Graphics Controller] (rev 03)
    00:1e.0 PCI bridge: Intel Corp. 82801AA PCI Bridge (rev 02)
    00:1f.0 ISA bridge: Intel Corp. 82801AA ISA Bridge (LPC) (rev 02)
    00:1f.1 IDE interface: Intel Corp. 82801AA IDE (rev 02)
    00:1f.2 USB Controller: Intel Corp. 82801AA USB (rev 02)
    00:1f.5 Multimedia audio controller: Intel Corp. 82801AA AC'97 Audio (rev 02)

    # uname -a
    Linux localhost 2.6.5-1.358 #1 Sat May 8 09:04:50 EDT 2004 i686 i686 i386 GNU/Linux

    # ls -al /dev | grep cdrom
    lrwxrwxrwx 1 root root 8 Aug 2 2003 cdrom -> /dev/hdd
    lrwxrwxrwx 1 root root 9 Aug 2 2003 cdrom1 -> /dev/scd0

  4. #4
    Just Joined!
    Join Date
    Aug 2004
    Location
    India
    Posts
    46

    cdrom mystery solved

    I found out that in grub.conf, a kernel argument "hdc=ide-scsi" was being passed. On removing that and mounting /dev/hdc on /mnt/cdrom, the problem was solved.

    But the sound problems still persist. Can anyone atleast give me a starting point for troubleshooting that ?

  5. #5
    Just Joined!
    Join Date
    Aug 2004
    Location
    India
    Posts
    46

    problem solved

    I dont know what the problem was but tinering around a bit solved it. But i found out that my sound does not work in gnome, only kde. It works if I start artsd manually. Isn't it supposed to work without that???

    If I select any other output plugin in xmms except arts (among OSS, ALSA, and ARTS), i get an error saying my sound card is not configured properly.

    how do i configure my sound card? I have onboard ac97 sound on an intel 810 motherboard.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •