Find the answer to your Linux question:
Results 1 to 2 of 2
I want to set up a multiboot PC, but can't get Win NT 4 to start when using GRUB in Red Hat 9 - has anyone had this problem and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Location
    Berkshire, England, UK
    Posts
    2

    GRUB multiboot on RH9 wont start NT4


    I want to set up a multiboot PC, but can't get Win NT 4 to start when using GRUB in Red Hat 9 - has anyone had this problem and solved it ?

    I set up the partitions so that I could multiboot several MS operating
    systems plus Red Hat Linux 9
    /dev/hda0 win NT
    /dev/hda1 linux root
    /dev/hda2 win XP
    /dev/hda3 extended partition
    /dev/hda7 win 98
    /dev/hda8 DOS

    The remaining various Linux file systems were set to be in logical partitions in the extended partition

    Using Partition Magic 6, I was able to install win NT and win XP and get them to start by changing the active partition. Win NT was installed
    direct from the CD without any Service Pack upgrades, as the intention
    was to put these on once the multiboot was in place

    Then I installed RH9 which put GRUB into /dev/hda - I read conflicting articles that suggested that GRUB should/should not go in /dev/hda, so in the end decided to install at /dev/hda - I believe this is known as the Master Boot Record

    I rebooted the PC which displayed the expected boot menu
    Both win XP and RH 9 start correctly, but win NT does not boot

    When NT is selected from the boot menu, I get the following:
    1) I first get the OS loader screen with the timeout to start
    2) I next get a couple of blue screens with displays similar to
    NT Version 4
    1 System Processor [ 512M ]
    3) Then I get a full blue screen of diagnostics ('blue screen of death'), but the salient line
    is probably:
    *** STOP:
    INACCESSIBLE_BOOT_DEVICE


    The hardware is:
    Motherboard AOpen MK79G-1394
    Processor AMD ATHLON XP2800+ 333MHZ FSB 512Cache L2 Cache CPU Barton - OEM
    Amd Xp3200+ Air Cool Copper Base + 3 Point Clip
    Memory Crucial 512 DDR333 PC2700 DIMM
    Hard drive Hitachi 7K250 Deskstar 160gb ATA100 7200rpm 8mb Cache - OEM


    I've tried a few other things for a solution, but as yet no joy - still get INACCESSIBLE_BOOT_DEVICE when starting win NT4 from GRUB

    a) tried adding various combinations of
    unhide (hd0,0)
    hide (hd0,2)
    makeactive
    into grub.conf, but these made no difference - the entry for NT is

    title WINNT
    rootnoverify (hd0,0)
    chainloader +1



    b) the post at
    http://lists.gnu.org/archive/html/bu.../msg00165.html
    suggests that GRUB needs a change to the first instruction of the 'stage1' file
    This applies to RH7.3 with NT4 SP3
    I have RH9 and NT SP1 (because I'd planned to upgrade after I had the boot menu)

    Does anyone know if this problem has been fixed in RH9 - if not, how do I make this change - and is it relevant ?
    Does anyone know if I can / need to get NT 4 upto SP6 before I can get GRUB to start NT4
    If I can get NT4 to start on SP1, will I be able to upgrade to SP6 without screwing the GRUB start ?

    Any help on this will be much appreciated
    Thanks

  2. #2
    Just Joined!
    Join Date
    Sep 2004
    Location
    Berkshire, England, UK
    Posts
    2
    Here's the partition table from fdisk -l /dev/hda

    Disk /dev/hda: 164.6 GB, 164696555520 bytes
    255 heads, 63 sectors/track, 20023 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/hda1 * 1 510 4096543+ 7 HPFS/NTFS
    /dev/hda2 511 1020 4096575 83 Linux
    /dev/hda3 1021 2040 8193150 17 Hidden HPFS/NTFS
    /dev/hda4 2041 20023 144448447+ f Win95 Ext'd (LBA)
    /dev/hda5 2041 7140 40965718+ 7 HPFS/NTFS
    /dev/hda6 7141 7268 1028128+ 7 HPFS/NTFS
    /dev/hda7 7269 7396 1028128+ 1b Hidden Win95 FAT32
    /dev/hda8 7397 7524 1028128+ 16 Hidden FAT16
    /dev/hda9 7525 7786 2104483+ 82 Linux swap
    /dev/hda10 7787 13523 46082421 83 Linux
    /dev/hda11 13524 14798 10241406 83 Linux
    /dev/hda12 14799 16073 10241406 83 Linux
    /dev/hda13 16074 18623 20482843+ 83 Linux
    /dev/hda14 18624 20023 11245468+ 83 Linux

    WIN NT is on the first parition, linux root (contains /boot) is on the second partition, Win XP is on the third partition

    Anyone out there got any ideas ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •