Find the answer to your Linux question:
Results 1 to 3 of 3
All, I am running Fedora 10 and working with sendmail to send messages via various scripts. I've gotten everything working and under normal circumstances the messages get delivered as expected. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    13

    sendmail not processing messages after reboot - possible sendmail bug


    All,

    I am running Fedora 10 and working with sendmail to send messages via various scripts. I've gotten everything working and under normal circumstances the messages get delivered as expected. However when I reboot my computer, all mail designated for sendmail gets hung up in the queue. I've confirmed that sendmail is set to start on boot (runlevel 5) and I've checked for the existence of sendmail processes (they indeed exist after boot).

    However, if I restart the sendmail daemon manually, everything in the queue gets sent and I get flooded with a backlog of emails from the past several hours (or days).

    Is there a reason or common problem as to why sendmail doesn't actually process mail after startup and why manually restarting the process seems to solve the problem? Is this a bug in sendmail?
    /var/log/maillog doesn't reveal anything out of the ordinary.

    Here's the pertinent info:
    sendmail-8.14.3-1.fc10.i386
    sendmail-cf-8.14.3-1.fc10.i386

    kernel 2.6.27.7-134.fc10.i686


    Thanks for any insight!
    Dan

  2. #2
    Just Joined!
    Join Date
    Jan 2009
    Posts
    1
    I'm going through the same thing as you described. It's almost certainly a DNS issue. If you send a msg by sendmail -tv you can see sendmail defers the message, typical when it fails DNS on the recipient. When you restart sendmail it picks up the right info which has been ready by then. Looks like when sendmail starts upon boot, DNS config in resolv.conf (or something similar) perhaps hasn't been ready, and that makes sendmail cache the wrong info or no info at all.

    The kicker is, I set up the same server in Vmware prior to doing it for real. The VM worked just fine. The only difference notable between the VM and the Dell I'm using is the Dell has two NICs, with eth1 not to go up on boot.

    I suspect NetworkManager has something to do with causing this.

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    13

    sendmail problem - SOLVED

    All,

    I solved this problem a few days ago and wanted to follow-up for those who may also have this problem.
    I also noticed problems with certain PHP webpages on my apache server. I had PHP scripts on certain pages that required an internet connection and noticed they were failing. This led me to believe that there was a problem independent of sendmail.

    I found instructions on how to disable NetworkManager at this site: http://www.mjmwired.net/resources/mj...0.html#network

    Reverting to the old "network" service solved all problems mentioned above. While I could have tweaked /etc/sysconfig/network and added NETWORKWAIT=1, I don't have any legitimate need for NetworkManager so disabling it was a simple solution.

    Dan

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •