Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    [SOLVED] fdisk -l cannot open /dev/sda - Fedora 10


    I was just poking around my system and looking at how things are set up when I tried to look at how my disk is partitioned (on a Dell 505 Latitude).

    Code:
    [***@localhost ~]$ fdisk -l
    Cannot open /dev/sda
    Code:
    [***@localhost ~]$ df -h
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/mapper/VolGroup00-LogVol00
                           22G   19G  2.0G  91% /
    /dev/sda3             190M   21M  160M  12% /boot
    tmpfs                 505M 1020K  504M   1% /dev/shm
    /dev/sda2              32G   30G  2.4G  93% /media/disk
    Why is fdisk unable to access the device?

  2. #2
    Linux Newbie bunty82's Avatar
    Join Date
    Sep 2007
    Location
    Asia
    Posts
    130
    May be you dont have the proper previledges root permissions.
    which is why bash is denying you from watching the contents.
    System Configuration
    OS#Windows Xp pro Sp2
    Intel Core 2 Duo 2.2ghz
    Intel motherboard DG965ry
    Nvidia graphic card 512mb
    2 gb ram
    250gb Sata segate HDD
    160gb sata segate hdd
    D link ethernetcard
    Lg dvd writer
    Lg cd writer

  3. #3
    <headdesk/>

    Yeah, that would do it. I just didn't think about it because it didn't say 'permission denied' or something along those lines.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •