Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 18 of 18
Originally Posted by loserbob4 the error screen in more discription reads like this: module loader present oskernel:linux version 2.4.18-14 (==)log file:"/var/log/XFree86.0.log",time thu sep 16 19:53 (==)using config file:"/etc/X11/XF86Config" (EE)no devices ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496

    Quote Originally Posted by loserbob4
    the error screen in more discription reads like this:

    module loader present
    oskernel:linux version 2.4.18-14
    (==)log file:"/var/log/XFree86.0.log",time thu sep 16 19:53
    (==)using config file:"/etc/X11/XF86Config"
    (EE)no devices detected

    Fatal error no screens found


    XIO: Fatal IO error 104(connection request by peer) on X server ":0.0" after 0 request (0 known processed) with 0 evens remaining.
    This looks to me like your XF86Config-4 did not get rewritten like it was supposed to when you ran xf86config. Did you make sure to run it as root? Also, could you post the contents of your /etc/X11/XF86Config-4 file?
    Registered Linux user #270181
    TechieMoe's Tech Rants

  2. #12
    Just Joined!
    Join Date
    Sep 2004
    Posts
    11
    ok im loged in as root. if thats what you mean as running it as root. im not sure how to check the contents of the file /etc/X11/XF86Conig-4. i typed that in but it just said no such file or directory. and when i trying just going to /etc.X11/XF86Config it says permission denied.

  3. #13
    Just Joined!
    Join Date
    Sep 2004
    Posts
    11
    ok i have been playing around in the settings and now the error screen says that the fatal server error is AddScreen/screenInit failed for driver 0

  4. #14
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by loserbob4
    ok im loged in as root. if thats what you mean as running it as root. im not sure how to check the contents of the file /etc/X11/XF86Conig-4. i typed that in but it just said no such file or directory. and when i trying just going to /etc.X11/XF86Config it says permission denied.
    Yes. When I say "run it as root" I mean "type the command after you've typed 'su' and entered your root password". The quickest way to get the contents of your /etc/X11/XF86Config-4 file is to type:

    Code:
    cat /etc/X11/XF86Config-4
    If you type that exactly as I have there, including the upper and lower case letters (Linux is case sensitive), and it tells you it can't find the file, we'll need to see what other files are in your /etc/X11 directory by typing:

    Code:
    ls /etc/X11/
    Note the command is "LS", not "1S", and it is in all lower case. You should either have a file named "XF86Config-4" or "Xorg.conf". To print the contents of them to the console, follow the "cat" command above. You can also open these files in any text editor, such as Emacs, Kedit, Gedit, AbiWord, OpenOffice, etc. All I need is to see what's in them.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  5. #15
    Just Joined!
    Join Date
    Sep 2004
    Posts
    11
    ok i have gotten xwindows to start but the resolution was terrible. everything was huge. also i couldn't move my mouse around?

  6. #16
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by loserbob4
    ok i have gotten xwindows to start but the resolution was terrible. everything was huge. also i couldn't move my mouse around?
    X Windows is probably set to whatever the default resolution was. You can change the default by opening up your /etc/X11/XF86Config-4 file as root and changing this section toward the bottom:

    Code:
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Videocard0"
    	Monitor    "Monitor0"
    	DefaultDepth     24
    	SubSection "Display"
    		Depth     24
    		Modes    "1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection
    The "Modes" section tells X Windows what resolutions to use. The first one is the default, and if it can't display that it works its way through each one from left to right.

    Your mouse probably just has the wrong mouse driver assigned to it. You can fix that by changing this section of your /etc/X11/XF86Config-4:

    Code:
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "IMPS/2"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "ZAxisMapping" "4 5"
    	Option	    "Emulate3Buttons" "yes"
    EndSection
    The "Protocol" section is what needs to be changed. Most 3-button mice with wheels are the "IMPS/2" as in the example above. Try that and see what happens.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  7. #17
    Just Joined!
    Join Date
    Sep 2004
    Posts
    11
    how do i open the file /etc/X11/Xf86config-4? do i just type that in after i loged on as root?

  8. #18
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by loserbob4
    how do i open the file /etc/X11/Xf86config-4? do i just type that in after i loged on as root?
    I believe I mentioned this before. You can open this file in any text editor, but to be able to change it you have to be logged in as root when you open it. Since you don't seem to be terribly familiar with the command line I'd recommend you open it in a graphical editor.

    Graphical editors need X Windows, so you'll need to do this while it's running, not from the command line. To do this as root, open up a console, log in as root by using the "su" command, then type this:

    Code:
    kate /etc/X11/XF86Config-4
    If your system doesn't use KDE, you won't have Kate, so try this:

    Code:
    gedit /etc/X11/XF86Config-4
    Lastly, if you don't have either of those, try a command-line editor:

    Code:
    pico /etc/X11/XF86Config-4
    Once you have it open, change what I mentioned above, then save it and exit X Windows and restart it. Also be careful not to close the console window while you're editing, because this will cause your editor to close as well.
    Registered Linux user #270181
    TechieMoe's Tech Rants

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •