Find the answer to your Linux question:
Results 1 to 10 of 10
HI I need to install this package(gnome-libs-1.4.1.2.90-44.1.x86_64.rpm) in redhat linux 5 for oracle 10 g requirements but it gives dependency error , it delays my oracle installiation I need some ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    3

    gnome-libs For Oracle 10g r2


    HI
    I need to install this package(gnome-libs-1.4.1.2.90-44.1.x86_64.rpm) in redhat linux 5 for oracle 10 g requirements
    but it gives dependency error , it delays my oracle installiation
    I need some expert people opinion how to fix this issue

    rpm -Uvh gnome-libs-1.4.1.2.90-44.1.x86_64.rpm
    warning: gnome-libs-1.4.1.2.90-44.1.x86_64.rpm: Header V3 DSA signature: NOKEY,
    key ID 652e84dc
    error: Failed dependencies:
    ORBit is needed by gnome-libs-1.4.1.2.90-44.1.x86_64
    gtk+ >= 1:1.2.5 is needed by gnome-libs-1.4.1.2.90-44.1.x86_64
    imlib is needed by gnome-libs-1.4.1.2.90-44.1.x86_64
    libIIOP.so.0()(64bit) is needed by gnome-libs-1.4.1.2.90-44.1.x86_64
    libORBit.so.0()(64bit) is needed by gnome-libs-1.4.1.2.90-44.1.x86_64
    libORBitCosNaming.so.0()(64bit) is needed by gnome-libs-1.4.1.2.90-44.1.x86_64
    libORBitutil.so.0()(64bit) is needed by gnome-libs-1.4.1.2.90-44.1.x86_64
    libdb.so.2()(64bit) is needed by gnome-libs-1.4.1.2.90-44.1.x86_64
    libdb.so.2(GLIBC_2.0)(64bit) is needed by gnome-libs-1.4.1.2.90-44.1.x86_64
    libgdk-1.2.so.0()(64bit) is needed by gnome-libs-1.4.1.2.90-44.1.x86_64
    libgdk_imlib.so.1()(64bit) is needed by gnome-libs-1.4.1.2.90-44.1.x86_64
    libglib-1.2.so.0()(64bit) is needed by gnome-libs-1.4.1.2.90-44.1.x86_64
    libgmodule-1.2.so.0()(64bit) is needed by gnome-libs-1.4.1.2.90-44.1.x86_64
    libgtk-1.2.so.0()(64bit) is needed by gnome-libs-1.4.1.2.90-44.1.x86_64
    libpng.so.2()(64bit) is needed by gnome-libs-1.4.1.2.90-44.1.x86_64



    i appreciate your advise
    rds

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    oracle 10g isn't supported on RHEL5, only on 4 or 3, you might be able to get it installed with -ignoreSysReqs flag

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    3
    HI
    Oracle 10g is supported in redhat 5 ,
    this is for ------> $ ./runInstaller -ignoreSysPrereqs
    invoke OUI

    BUT the package gnome-libs is a requirement package

    Installation of Oracle database 10g on RHEL 5

    rds

  4. #4
    Just Joined!
    Join Date
    Jan 2009
    Posts
    3
    pls provide a solution for this

    rds

  5. #5
    Just Joined!
    Join Date
    Mar 2009
    Posts
    1

    solved and tested

    There is actually a compatible library already installed as part of the gdbm-1.8.0-xx.x.x install, which is available for RHEL/OEL/CentOS

    All you need to do is add a symlink:

    ln -s /usr/lib/libgdbm.so.2.0.0 /usr/lib/libdb.so.2

    This solution has been found by Dave guy...from other forum...

  6. #6
    Just Joined!
    Join Date
    May 2009
    Posts
    2
    Quote Originally Posted by eMarcel View Post
    There is actually a compatible library already installed as part of the gdbm-1.8.0-xx.x.x install, which is available for RHEL/OEL/CentOS

    All you need to do is add a symlink:

    ln -s /usr/lib/libgdbm.so.2.0.0 /usr/lib/libdb.so.2

    This solution has been found by Dave guy...from other forum...

    On RHEL 5.2 x86_64 there is libgdbm.so.2.0.0 on /usr/lib64

    Both those links :

    ln -s /usr/lib64/libgdbm.so.2.0.0 /usr/lib/libdb.so.2
    ln -s /usr/lib64/libgdbm.so.2.0.0 /usr/lib64/libdb.so.2

    can't to solve the problem above (I've got package gnome-libs-1.4.1.2.90-44.1.x86_64.rpm from RHEL4.7)

  7. #7
    Just Joined!
    Join Date
    Jun 2009
    Posts
    1

    Hi

    Did you solve this? i have the same problem!

  8. #8
    Just Joined!
    Join Date
    May 2009
    Posts
    2
    Quote Originally Posted by gjergji View Post
    Did you solve this? i have the same problem!
    Yes, only glibc-devel-2.5-24.i386.rpm was needed to be installed
    (not any gnome-libs!)

  9. #9
    Linux Newbie ursusca's Avatar
    Join Date
    Dec 2008
    Location
    Toronto
    Posts
    116
    I installed oracle 10g several times on RHEL 5 and CentOS 5 (64bit). The package gnome-libs is not a requirement package. Instead of gnome-libs I installed:

    libgnome-2.16.0 (x86_64)
    libgnomeui-2.16.0 (x86_64)
    libXp-1.0.0-8 (i386)

    This is my example:
    uname -a
    Linux .... 2.6.18-128.1.6.el5 #1 SMP Tue Mar 24 12:05:57 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
    ~# rpm -qa | grep gnome-libs
    ~#

  10. #10
    Just Joined!
    Join Date
    Aug 2009
    Posts
    1
    Quote Originally Posted by eMarcel View Post

    There is actually a compatible library already installed as part of the gdbm-1.8.0-xx.x.x install, which is available for RHEL/OEL/CentOS

    All you need to do is add a symlink:

    ln -s /usr/lib/libgdbm.so.2.0.0 /usr/lib/libdb.so.2
    Thank you, it worked with CentOS 5.3 x86 with Oracle Application Server 10.1.3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •