Hi,

I am having problems with the usb system on Fedora Core 2. I have all
the latest updates. I am running Kernel 2.6.8.

kernel-2.6.8-1.521.i686.rpm
kernel-utils-2.4-9.1.131.i386.rpm
usbutils-0.11-4.i386.rpm

I found on other threads that changing the standard alias lines in
modprobe.conf which was set to this as default:

alias usb-controller ehci-hcd
alias usb-controller uhci-hcd

Looking at the posts, I then changed this to:

alias usb-controller uhci-hcd
alias usb-controller1 ohci-hcd

I also entered the following line into the rc.local file:

modprobe ohci-hcd uhci-hcd

My system is about 2 years old and is an Evesham chasis.

It has the following:

120GB first drive
80GB slave drive (linux installed on this drive)
nVidia GeForce 4 Ti2600 128MB RAM
6 USB 2.0 Ports
1 USB 1.0 4 Port Hub
HP DJ950C attached to usb
Logitech QuickCam Pro attached to USB
Microsoft Intellipoint Optical Mouse to USB
Keyboard to PS2 port
Microsoft Bluetooth Dongle to USB
Alcatel Speedtouch USB ADSL modem.
512 MB RAM
SoundBlaster Audigy soundcard.

PROBLEM:

After setting the files as shown above and rebooting this works
correctly and sets up the usb ports correctly. KUDZU on boot up detects
the quickcam and the printer and configures them. Subsequent reboots
within an hour have no affect and system works fine. After leaving the
computer for an extended period of time or after having worked in
Windows XP for a period of time and rebooting into Linux, usb
initialisation does not occur. On this boot up, KUDZU will detect the
absence of the printer and the camera and ask to remove the
configuration.

After completing boot up and changing the modprobe.conf and the rc.local
back to default and rebooting. On reboot the mouse does not work and
KUDZU does not detect anything else. If the files are then changed back
again to above and the system is rebooted then in most cases the usb is
initialised correctly and all USB devices work correctly including the
mouse.

In one case, the mouse also worked with the default setup as well.

Please could you advise me on what the problem maybe and how to solve
it. I have read that maybe I need ehci and ohci support but not uhci
support.

Regards

Ed Morris
edward@morris.vispa.com