Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hello, I have a lenovo laptop with Kernel : 2.6.25-14.fc9.x86_64 Network Controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev02) Ethernet controller : Broadcom Corporation Netlink BCM5906M Fast Ethernet PCI Express ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    pHa
    pHa is offline
    Just Joined!
    Join Date
    Mar 2009
    Posts
    6

    Wireless Not working - Lenovo Laptop Y410 : Kernel : 2.6.25-14.fc9.x86_64


    Hello,

    I have a lenovo laptop with

    Kernel : 2.6.25-14.fc9.x86_64

    Network Controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev02)
    Ethernet controller: Broadcom Corporation Netlink BCM5906M Fast Ethernet PCI Express (rev02)

    I have tried endlessly and unsuccessfully to make my wireless work.

    When I try to activate the device I got the message "Determining IP information for wlan0...SIOCSIFFLAGS: No such device"

    I followed the post at the following link.

    http://www.linuxforums.org/forum/red...onnection.html

    I had the following output for /sbin/lsmod | grep iwl3945

    iwl3945 170340 0

    which meant my drivers are fine.

    I downloaded firmware iwlwifi-3945-ucode-15.28.2.8.tgz from intel website which is the latest and put the required file in /lib/firmware/

    When I checked the sevices to restart the Network Manager and Network Manager Dispatcher I could find only Network Manager service running. I tried installing Network Manager Dispatcher via an RPM but it didnt appear in the list of services.

    Please help.

    Thanks pH

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Hmm. When clicking on the networkmanager icon in the systray, is the option to enable wireless grayed out? Do you by chance have a physical kill switch on your computer that is maybe switched off? (I've done that before.) Can you post the output of
    Code:
    dmesg | grep iwl
    ifconfig
    iwconfig
    su -c 'iwlist wlan0 scanning'

  3. #3
    pHa
    pHa is offline
    Just Joined!
    Join Date
    Mar 2009
    Posts
    6
    Hi Reed9,

    First of all sorry for late response. I am in a different time zone.

    When clicking on the networkmanager icon in the systray, the option to enable wireless is grayed out.
    I have a physical switch but its turned ON.

    Following is the output of the commands.

    # dmesg | grep iwl
    iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26kds
    iwl3945: Copyright(c) 2003-2008 Intel Corporation
    iwl3945: Detected Intel Wireless WiFi Link 3945ABG
    iwl3945: Tunable channels: 11 802.11bg, 13 802.11a channels
    phy0: Selected rate control algorithm 'iwl-3945-rs'
    iwl3945: Radio disabled by HW RF Kill switch
    iwl3945: Radio disabled by HW RF Kill switch
    iwl3945: Radio disabled by HW RF Kill switch
    iwl3945: Radio disabled by HW RF Kill switch
    iwl3945: Radio disabled by HW RF Kill switch
    iwl3945: Radio disabled by HW RF Kill switch
    iwl3945: Radio disabled by HW RF Kill switch
    iwl3945: Radio disabled by HW RF Kill switch
    iwl3945: Radio disabled by HW RF Kill switch
    iwl3945: Radio disabled by HW RF Kill switch
    iwl3945: Radio disabled by HW RF Kill switch
    iwl3945: Radio disabled by HW RF Kill switch

    # /sbin/ifconfig
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:3174 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3174 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:158932 (155.2 KiB) TX bytes:158932 (155.2 KiB)

    # /sbin/iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wmaster0 no wireless extensions.

    wlan0 IEEE 802.11 ESSID:""
    Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
    Tx-Power=0 dBm
    Retry min limit:7 RTS thr:off Fragment thr=2352 B
    Encryption key:3141-3242-3343-3444-3545
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    pan0 no wireless extensions.


    # su -c 'iwlist wlan0 scanning'
    bash: iwlist: command not found

  4. #4
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    iwl3945: Radio disabled by HW RF Kill switch
    If you have your radio turned on via the hardware switch, and are getting this message, then there must be a software switch that is enabled. I had to do this once before for an ipw2200, but I can't remember exactly how to do it.

    I believe this should tell you the state of the kill switch.
    Code:
    cat /sys/bus/pci/drivers/iwl3945/*/rf_kill
    The output should be 0, to indicate your wireless radio is on.

    And I think you can change it as so
    Code:
    echo 0 > /sys/bus/pci/drivers/iwl3945/*/rf_kill
    You need root privileges to change this, I think, as well.

  5. #5
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You are basically correct on this, but you may need a more specific path for the command. I gathered some notes on this, so I'll post them as is.
    RFKILL (RF_KILL)

    To check kill switch state:
    cat /sys/bus/pci/devices/0000\:03\:00.0/rf_kill

    This should be modified for your card location

    # cat /sys/bus/pci/drivers/iwl3945/module/drivers/pci\:iwl3945/0000\:10\:00.0/rf_kill
    2

    AFAIK there are 4 value for rf_kill, like the following,
    0 -- means both software/hardware rf_kill are disabled;
    1 -- means software rf_kill is enable;
    2 -- means hardware rf_kill is enable;
    3 -- means both software/hardware rf_kill are enabled

    and after:

    # echo "1" >> /sys/bus/pci/drivers/iwl3945/module/drivers/pci\:iwl3945/0000\:10\:00.0/rf_kill

    # cat /sys/bus/pci/drivers/iwl3945/module/drivers/pci\:iwl3945/0000\:10\:00.0/rf_kill
    3

    Remove and reload the module after changing the state of it.
    I gathered these notes, mostly, from here:

    Bug 1454 – on Fedora (rawhide) iwl3945 module loads but doesn't work (RF kill switch issue)

    This only covers the rf_kill module that is present in the Intel driver. Newer kernels have the rfkill (spelled different) module as a separate module. It is slightly different.
    Please do not send Private Messages to me with requests for help. I will not reply.

  6. #6
    pHa
    pHa is offline
    Just Joined!
    Join Date
    Mar 2009
    Posts
    6
    Thanks guys for your inputs.
    I tried doing an "echo 1 > /sys/bus/pci/drivers/iwl3945/*/rf_kill" and it changed the value to 3. But doesnt help and when I restart my machine its 2 again.

    @waterhead, what is meant by

    Remove and reload the module after changing the state of it.

  7. #7
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The module referred to is the kernel module that contains the driver for your wireless card. In this case it is named iwl3945. You can remove a module using the modprobe command, with the -r option. First gain root privileges using the su command.
    Code:
    modprobe -r iwl3945
    Then you can reload it.
    Code:
    modprobe iwl3945
    I tried this on my working wireless, that uses the ath5k driver. I was able to disable it, but after changing the state back, I wasn't able to enable the wireless. Even after unloading and reloading the module. I had to reboot to get the wireless to work again.

    Have you tried setting the state to 0? Then try unloading/reloading the module, then reboot. If the wireless was never configured, it may still not work. You need to open the "Network" program (In System-->Administration) and configure it. Click on "Edit", and make sure the "Use NetworkManager" and "Allow All users to enable/disable" options are checked.
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #8
    pHa
    pHa is offline
    Just Joined!
    Join Date
    Mar 2009
    Posts
    6
    hi paul,

    I tried doing the echo to change rf_kill value to 3. But when I do a modprobe -r and then a modprobe it gets reset to 2.

    I am not able to se the rf_kill to 0 in any case. It never goes below the value of 2.

    I did the above after "enabling" the '"Allow All users to enable/disable" the network device but no luck

    thmx pH

  9. #9
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You may need to enter the BIOS and see if there is a setting to activate the wireless.
    Please do not send Private Messages to me with requests for help. I will not reply.

  10. #10
    pHa
    pHa is offline
    Just Joined!
    Join Date
    Mar 2009
    Posts
    6
    Thanks paul. I wonder why it never worked. I did wht this thread says and its up now,,,

    Wireless - Determining IP information for wlan0...failed; no link present...... - FedoraForum.org

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •