Find the answer to your Linux question:
Results 1 to 4 of 4
Yeah, I know, I did something very stupid! I was making some upgrades on my Red Hat 7.3 server carelessly and now I'm $90 in tech support debt ($45 per ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    3

    Installed Fedora Glibc Upgrade On Rh 7.3, Help!


    Yeah, I know, I did something very stupid! I was making some upgrades on my Red Hat 7.3 server carelessly and now I'm $90 in tech support debt ($45 per half hour) and still no solution. I run about 7 websites and my Apache web server (self-managed) won't start...

    Here is what my Apache error log says:

    /usr/sbin/httpd: relocation error: /lib/libpthread.so.0: symbol __libc_fork, version GLIBC_2.1.2 not defined in file libc.so.6 with link time reference
    Right now I can't even use the tar command (get a similar error to the one above) so I have to rely on RPM packages for fixes.

    Here is the history of my tech support replies:
    We have reinstalled glibc and your system is now booting and accessible via ssh. However, there are still some applications that appear to have issues, including Apache and Bind. It is possible that they will have to be reinstalled as well, but we felt at this point now that you can log in that we should give you the option of fixing these yourself. You have currently incurred one hour of admin time, chargeable at $45 per half hour under the self-managed plan. Please let us know how you would like us to proceed.
    -----------------------------
    We have reinstalled the base glibc installation from Redhat 7.3, but it appears that you are still having errors when loading Apache and BIND.

    The RPM's we installed are:
    glibc-2.2.5-34-i386.rpm
    glibc-common-2.2.5-34.i386.rpm
    glibc-devel-2.2.5-34.i386.rpm
    glibc-kernheaders-2.4-7.14.i386.rpm

    These are packages from your original installation. I need to know if you have installed any additional packages that we might not be aware of. From what I can see, all of your package versions look to be correct. Please update this ticket and let us know if we are missing something.
    -----------------------------
    The Glibc for Fedora RPM's were installed on the server Ver Red Hat 7.3. Which broke many dependencies on your server. This is a bilable issue this will take aprox about 1 hour to fix.
    Please call our tech support department if you have any questions.
    If anyone has any ideas on a possible solution, please let me know, as I've been spending hours on this problem and still coming to no solution. Any help would be much appreciated!

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Ouch...sounds not fun. Anyway...on to business (I only charge $30/half hour ). You can't run tar, eh? Try to re-install tar via an RPM...see if that fixes tar's behaviour. If that is the case, it's pretty safe to assume that you'll have to re-install every package on your system. If it doesn't work, let us know...we'll ponder it some more.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Sep 2004
    Posts
    3
    Hmm well I tried installing the TAR RPM and got this:
    tar-1.13.25-4.i386.rpm: read manifest failed: Success

    But now TAR seems to work okay... But when I tried re-installing Apache, I get this error:
    checking for gcc... gcc
    checking for C compiler default output... configure: error: C compiler cannot create executables
    Not really sure where to go from here... I am guessing there is still a problem with GLIBC? Been trying to install glibc 2.1.2 because I figured if I could get that back then everything would be in its original state. Only problem is that glibc says my gcc and makeinfo are bad...

    checking for a BSD compatible install... /usr/bin/install -c
    checking whether ln -s works... yes
    checking build system type... i686-pc-linux-gnu
    checking for gcc... gcc
    checking version of gcc... 3.2.3, bad
    checking for make... make
    checking version of make... 3.79.1, ok
    checking for msgfmt... msgfmt
    checking version of msgfmt... 0.10.32, ok
    checking for makeinfo... makeinfo
    checking version of makeinfo... 4.1, bad
    configure: error:
    *** Some critical program is missing or too old.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2004
    Posts
    3
    I ended up installing YUM and doing an update, and now everything seems to be fixed! Yum rocks...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •