Find the answer to your Linux question:
Results 1 to 2 of 2
I am running Fedora Core 2. I have a Conexant HSF 56K HSFi modem in my computer, but it will not dial up for me. It is recognized when I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    1

    Modem issues...


    I am running Fedora Core 2. I have a Conexant HSF 56K HSFi modem in my computer, but it will not dial up for me. It is recognized when I run scanpci and I assigned it to ttyS3 using setserial. When I run ppp-on-dialer I am presented with the following:
    rAT
    which soon becomes:
    ++++

    Then the command line comes up again and I am not connected... not to mention the lack of normal dial-up modem noises. I downloaded a driver from linuxant.com but the trial only supports 14K and you have to pay for the full thing. Not to mention that it didn't help at all anyway. If you have any advice or possible software for me to try (preferrably free) I would greatly appreciate it.

    Thanks.
    Kevin

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    doesn't look like your modem is talking. The AT command should be responded, by your modem with OK. It's this simple handshake that tells your PC that the modem is talking to it.

    In your post you say that rAT is sent, perha[s this is the problem. Your modem is expecting a standard Hayes modem command string (they all start AT and then something, such as ATDT says Dial, using tones, the following number, and ATW2DT says first when you get a connection show me the correct connection speed, followed by and now dial, using tones, the following number).

    Or it could be that your dial up script is point at the wrong device, try making a symbolic link between /dev/ttyS3 /dev/modem (nb. may already exist, so first have a look at /dev/modem - ls /dev/mod* -alF)

    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •