Find the answer to your Linux question:
Results 1 to 6 of 6
Anyone seen this error from Makefile openssl if [ "" = "hpux-shared" -o "" = "darwin-shared" ] ; then \ cc -o openssl -DMONOLITH -I.. -I../include -DOPENSSL_NO_KRB5 -O openssl.o verify.o ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    2

    HELP


    Anyone seen this
    error from Makefile openssl
    if [ "" = "hpux-shared" -o "" = "darwin-shared" ] ; then \
    cc -o openssl -DMONOLITH -I.. -I../include -DOPENSSL_NO_KRB5 -O openssl.o verify.o asn1pars.o req.o dgst.o dh.o dhparam.o enc.o passwd.o gendh.o errstr.o ca.o pkcs7.o crl2p7.o crl.o rsa.o rsautl.o dsa.o dsaparam.o x509.o genrsa.o gendsa.o s_server.o s_client.o speed.o s_time.o apps.o s_cb.o s_socket.o app_rand.o version.o sess_id.o ciphers.o nseq.o pkcs12.o pkcs8.o spkac.o smime.o rand.o engine.o ocsp.o ../libssl.a ../libcrypto.a ; \
    else \
    LD_LIBRARY_PATH=..:$LD_LIBRARY_PATH \
    cc -o openssl -DMONOLITH -I.. -I../include -DOPENSSL_NO_KRB5 -O openssl.o verify.o asn1pars.o req.o dgst.o dh.o dhparam.o enc.o passwd.o gendh.o errstr.o ca.o pkcs7.o crl2p7.o crl.o rsa.o rsautl.o dsa.o dsaparam.o x509.o genrsa.o gendsa.o s_server.o s_client.o speed.o s_time.o apps.o s_cb.o s_socket.o app_rand.o version.o sess_id.o ciphers.o nseq.o pkcs12.o pkcs8.o spkac.o smime.o rand.o engine.o ocsp.o -L.. -lssl -L.. -lcrypto ; \
    fi
    /usr/bin/ld: skipping incompatible /usr/lib/gcc-lib/s390x-redhat-linux/3.2.3/../../../libc.so when searching for -lc
    /usr/bin/ld: skipping incompatible /usr/lib/gcc-lib/s390x-redhat-linux/3.2.3/../../../libc.a when searching for -lc
    /usr/bin/ld: skipping incompatible /usr/lib/libc.so when searching for -lc
    /usr/bin/ld: skipping incompatible /usr/lib/libc.a when searching for -lc
    /usr/bin/ld: cannot find -lc
    collect2: ld returned 1 exit status
    make[1]: *** [openssl] Error 1
    make[1]: Leaving directory `/opt/tools/openssl-0.9.7d/apps'

  2. #2
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    158
    Hi,

    I haven't seen this problem specically but I had other problems when compiling openssl...

    what options are you running with you ./config?

    I had problems with the crypto and had to run with ./config no-dso

    //jonas[/code]

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    2

    Options

    VERSION=0.9.7d
    MAJOR=0
    MINOR=9.7
    SHLIB_VERSION_NUMBER=0.9.7
    SHLIB_VERSION_HISTORY=
    SHLIB_MAJOR=0
    SHLIB_MINOR=9.7
    SHLIB_EXT=
    PLATFORM=dist
    OPTIONS= no-krb5
    CONFIGURE_ARGS=dist
    SHLIB_TARGET=

  4. #4
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    158
    Hi,

    I think that you have to start by doing a
    Code:
    ./config
    from your source tree...

    I just downloaded and compiled successfully on a FC2.

    Here are my steps;
    1. download and unpack
    2. ./config
    3. make
    4. make test
    5. make install

    Let me know if it helps...

    //jonas

  5. #5
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    that should be './configure' not './config'
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  6. #6
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    158
    that should be './configure' not './config'
    No it should not be ,/configure... It is ./config

    //jonas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •