Find the answer to your Linux question:
Results 1 to 7 of 7
Hi All, I am using redhat el5.. Here in my network i want to block usb drives.So user cant able to access their pen drives. But unfortunately our system mouse ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2008
    Posts
    3

    Usb disable


    Hi All,

    I am using redhat el5.. Here in my network i want to block usb drives.So user cant able to access their pen drives. But unfortunately our system mouse also usb mouse. So pls guide how to disable only for pendrives. Thanks in advance.

  2. #2
    Linux Enthusiast meton_magis's Avatar
    Join Date
    Oct 2006
    Location
    arizona
    Posts
    699
    I know devicekit is what Fedora is currently using for this kinda stuff, but I dont know if it is in RHEL yet.


    #############EDIT################
    never mind, I just found out it is GOING to be in Fedora 11 .... oops
    New to the internet, technical forums, or the hacker / open source community??
    Read this to learn good posting habits http://www.catb.org/~esr/faqs/smart-questions.html

    RHCE for RHEL version 5
    RHCT for RHEL version 4

  3. #3
    Just Joined!
    Join Date
    Feb 2008
    Posts
    3

    hi

    HI ,

    Thank you for your reply.I will try this in rhel 5.

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,393
    You can keep them from being automounted by disabling the autofs service. Once that is done, in order for a user to mount the USB drive, they would need root privileges. This probably will disable automounts of CD/DVD discs as well.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  5. #5
    Just Joined!
    Join Date
    Jan 2007
    Location
    San Antonio, TX
    Posts
    21
    Another option is to disable the 'usb-storage' kernel module from being loadable by either moving the kernel module.

    ----
    mv /lib/modules/`uname -r`/kernel/drivers/usb/storage/usb-storage.ko /lib/modules/`uname -r`/kernel/drivers/usb/storage/usb-storage.ko.bk
    ----

    Or simply blacklisting the module within '/etc/modprobe.d/blacklist'.

  6. #6
    Just Joined!
    Join Date
    Feb 2008
    Posts
    3

    Hi All

    Hi


    Thank you guys for your immediate reply.I hope this information sounds good.

  7. #7
    Just Joined!
    Join Date
    Mar 2012
    Posts
    1
    Quote Originally Posted by Rubberman View Post
    You can keep them from being automounted by disabling the autofs service. Once that is done, in order for a user to mount the USB drive, they would need root privileges. This probably will disable automounts of CD/DVD discs as well.
    How can i disable autofs service?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •