Find the answer to your Linux question:
Results 1 to 5 of 5
I have just finished compiling my own 2.6.8.1 kernel, and built my device drivers into the kernel (they aren't modules) When I boot the kernel I get the following error: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jun 2004
    Posts
    220

    What does this Kernel Error Mean?


    I have just finished compiling my own 2.6.8.1 kernel, and built my device drivers into the kernel (they aren't modules) When I boot the kernel I get the following error:
    Code:
    VFS&#58; Cannot open root device "<NULL>" or unknown-block&#40;3,7&#41;
    please append a correct "root=" boot option.
    Kernel panic&#58; VFS&#58; Unable to mount root fs on unknown-block &#40;3,7&#41;
    What should the root= option in the grub.conf file look like? (is it the same as my root partition? (hd0,x)?) I originally copied the configuration syntax from other entries (that work) in my config file. When I got a similar error to the above (but earlier i n the boot sequence) I googled and found that removing the root=label=/ option helped. It did, untill a few lines down I got the above error. Any Suggestions?

    Sorry for the long post
    N3WO

    There are 10 types of people; those who count in binary and those who don\'t...

  2. #2
    Linux Newbie
    Join Date
    Jul 2004
    Location
    www.syracuse.com
    Posts
    119
    here is my grub.conf file if you would like to see one.

    default 0
    timeout 5
    splashimage=(hd0,0)/grub/splashimage.xpm.gz

    title=Gentoo Linux 2.6.8-r3
    root=(hd0,0)
    kernel /kernel-2.6.8-gentoo-r3 root=/dev/hda3 gentoo=nodevfs
    i beleive your problem is due to the fact that you have neither devfs or udev running on your computer. you should configure one or the other to run on your computer. your problem could also be due to you not compiling in support for the file system that you are trying to use.

    try posting your actual grub.conf file, and hopefully someone can give you specifics. good luck with it all, cuz it's all worth it in the end.

  3. #3
    Linux Newbie
    Join Date
    Jun 2004
    Posts
    220
    ok I looked into devfs, and found that my /etc/rc.d/rc.sysinit file included the devfs line recommended in the devfs faq, so I assume it's installed and being run. Here's my Grub.conf file
    Code:
    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE&#58;  You have a /boot partition.  This means that
    #          all kernel and initrd paths are relative to /boot/, eg.
    #          root &#40;hd0,5&#41;
    #          kernel /vmlinuz-version ro root=/dev/hda7
    #          initrd /initrd-version.img
    #boot=/dev/hda
    default=0
    timeout=10
    splashimage=&#40;hd0,5&#41;/grub/splash.xpm.gz
    title Fedora Core &#40;2.6.5-1.358smp&#41;
            root &#40;hd0,5&#41;
            kernel /vmlinuz-2.6.5-1.358smp ro root=LABEL=/ rhgb quiet
            initrd /initrd-2.6.5-1.358smp.img
    title Fedora Core Personal
            root &#40;hd0,5&#41;
            kernel /vmlinuz-2.6.8.1-10-6-04 ro root=/dev/hda7
    title Fedora Core-up &#40;2.6.5-1.358&#41;
            root &#40;hd0,5&#41;
            kernel /vmlinuz-2.6.5-1.358.save ro root=LABEL=/ rhgb quiet
            initrd /initrd-2.6.5-1.358.img
    title WinXP
            rootnoverify &#40;hd0,1&#41;
            chainloader +1
    I tried root=LABEL=/, and still got an error.


    ps, it's the fedora core personal entry that I'm concerned about. All the others boot fine. (even, sadly, winxp...)
    N3WO

    There are 10 types of people; those who count in binary and those who don\'t...

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! bclark4444's Avatar
    Join Date
    Dec 2003
    Posts
    55
    Im not positive, however, i noticed that your "Fedora Core Personal" is missing its 'initrd ' line. You may want to try and add that and see if it fixes your issue.

  6. #5
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Quote Originally Posted by n3wo
    I tried root=LABEL=/, and still got an error.
    If the / partition for your new kernel is different from the / partition for your old, then it won't have the same "LABEL" and may have no LABEL at all. You can give it a LABEL with the command e2label. This is a really useful command: with multiple / partitions, etc, you can give each a descriptive label so when you run mount, or cat fstab, you don't have to remember partition numbers.
    Quote Originally Posted by n3wo
    What should the root= option in the grub.conf file look like? (is it the same as my root partition? (hd0,x)?)
    Note that while the first line of the GRUB block "root (hd0,5)" uses numbers for drive and partition and counts from zero (and it points to the /boot partition, not /), the kernel line reference to "root" points to the / partition and uses the format that the rest of Linux does as in hda7. Is your new / partition really on hda7?

    I just noticed bclark4444's post. He's got a sharp eye.
    /IMHO
    //got nothin'
    ///this use to look better

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •