Find the answer to your Linux question:
Results 1 to 7 of 7
hi i'm a new linux and i have finished setup fedora 10 on PC. my soundcard is on board and it good before when i used windows xp. but when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2009
    Posts
    4

    Angry no sound on Fedora


    hi i'm a new linux and i have finished setup fedora 10 on PC. my soundcard is on board and it good before when i used windows xp. but when i use fedora, it no sound. i have looked for on internet and all solutions seem doesn't work. can u tell how to fix this problem? thanks!

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Welcome to the forums!

    Can you tell us what sound device you are using?

    Also, check to be sure that volume isn't muted because it often is, by default.
    oz

  3. #3
    Just Joined!
    Join Date
    Jun 2009
    Posts
    4
    hey, here is my sound device:
    00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
    i retrieve it from command lspci
    the full infomation of my PC is:
    [reds@july-huyentrang ~]$ lspci
    00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
    00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
    00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
    00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
    00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
    00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
    00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
    00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
    00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
    00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
    00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
    00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
    00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
    00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
    01:04.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

    thanks!

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,444
    Go to the audio mixer and check the PCM level. It is often off (0) by default, resulting in no audio output. Move it to the highest setting, and adjust your volume with the master volume control.

    Also, you should be using the ALSA sound system and drivers.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  5. #5
    Just Joined!
    Join Date
    Jun 2009
    Posts
    4
    im using ALSA driver. your idea is confuse. i cant find audio mixer in fedora 10. i know that the older version of fedora has the software to detect audio card. but im using version 10. it have one way to set audio by visualization tool:
    Preference --> Hardware --> Sound and set somthing here.
    i set every thing and click test but i hear no sound, both front and back.
    some friend tell me if i want to write c++ program, i must use linux. i used linux some day ago and i find i realy well. but the bit happiness when i use linux is music does no work. my friends have sent me some advises, and i also look for on internet, but i not find good solution to solve my problem.

  6. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,444
    Are you running the KDE or Gnome desktop environment? If running KDE, then open a command-line window and enter the command: kmix
    That is the KDE audio mixer UI. In the Output section, you should see sliders for Master, PCM, Front, Line, CD, Mic, and Digital. Set the sliders for PCM and Front to the top (highest value) and Master somewhere about 1/2 way. I usually set CD to the top as well, though I never have found that it affects anything.

    If when you start kmix you only see an icon on your shortcut panel, then click on that, and then on the Mixer button at the bottom of the volume slide.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  7. #7
    Just Joined!
    Join Date
    Jun 2009
    Posts
    4

    Talking

    i use gnome. i see your solution but my sound does not mute. some guy in the fedora forum tell me write command : alsaunmute. and the result:
    Unknown hardware: "HDA-Intel" "Realtek ALC880" "HDA:10ec0880" "0x1043" "0x81a7"
    Hardware is initialized using a guess method
    i dont know what it mean??. why it is initialized by a guess mode and why linux doesn't fix this problem to make life easy?
    and at last i guess that this driver does not support my sound card . it to bad . so i have installed two OS on my PC, windows xp to listen music and fedora to work . i think it is good idea

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •