Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    tar: v: Cannot open: No such file or directory


    hi,

    I'm a new linux user. And I'm trying to install Sybase on my Linux. But I met a lot of problem.

    I have installed the sybase successfully but the server cannot be started. And the error is that: ./startserver: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory

    And then I download the " libaio-0.3.105-2.i386.rpm", and used the rpm command to install: rpm -ivh libaio-0.3.105-2.i386.rpm
    but it said: " libaio-0.3.105-2.i386.rpm: not an rpm package (or package manifest):"

    And then I download the "libaio-0.3.106.tar.gz", and tried to use tar command to install : tar -zxfv libaio-0.3.106.tar.gz
    but it said: "tar: v: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: libaio-0.3.106.tar.gz: Not found in archive
    tar: Error exit delayed from previous errors
    "

    I really don't know what to do and hope someone can help me.

  2. #2
    Just Joined! gkiran.linux's Avatar
    Join Date
    Jun 2008
    Location
    Hyderabad
    Posts
    6
    Hi

    Please check whether you have enough disk space to install it also try to use relative path rather than absolute path.

    Kiran

  3. #3
    tar -zxfv libaio-0.3.106.tar.gz
    You have your tar options in the wrong order. The -f option must be the last one, since that is the one that looks for a filename argument. Right now, in the order you have your options, tar is looking for a file name 'v'. It is not taking v as the verbose argument.

    $tar -xzvf <targetfile>

  4. $spacer_open
    $spacer_close
  5. #4
    Quote Originally Posted by LazarusLong View Post
    You have your tar options in the wrong order. The -f option must be the last one, since that is the one that looks for a filename argument. Right now, in the order you have your options, tar is looking for a file name 'v'. It is not taking v as the verbose argument.

    $tar -xzvf <targetfile>
    It worked! Thank you very much!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •