Find the answer to your Linux question:
Results 1 to 10 of 10
Hi there, I really do need those packages to install my wacom on RHEL. I was successful with them on CentOs, not here. Yum says: No package xorg-x11-server-sdk available. No ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2010
    Posts
    21

    [SOLVED] yum install xorg-x11-server-sdk libXi-devel problem


    Hi there,

    I really do need those packages to install my wacom on RHEL. I was successful with them on CentOs, not here. Yum says:

    No package xorg-x11-server-sdk available.
    No package libXi-devel available.

    I have tried to download them manually, but there were dependencies failures which I was unable to solve. My RHEL is fully updated, registered.

    Can you please advise me what should I do?
    Tkanks, Pidiclovek

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Which version of RHEL are you using? It is available in RHEL 5 Desktop and Server.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jun 2010
    Posts
    21
    Hi, thanks for reply, I am using RHEL 5.5 currently. I am using this official repository (Red Hat Enterprise Linux Desktop (v.5 for 64-bit x86_64)), but yum still says that there is no package available.

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Post the output of this
    Code:
    su -
    yum repolist
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Jun 2010
    Posts
    21
    That's just it:

    [root@localhost ~]# yum repolist
    Loaded plugins: rhnplugin, security
    repo id repo name status
    rhel-x86_64-client-5 Red Hat Enterprise Linux Desktop (v. 5 for 6 enabled: 7,204
    repolist: 7,204
    it's a fresh new install....

  7. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Only one repository has been enabled.
    Post the output of this
    Code:
    ls /etc/yum.repos.d
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #7
    Just Joined!
    Join Date
    Jun 2010
    Posts
    21
    [root@localhost ~]# ls /etc/yum.repos.d
    atomic.repo mirrors-rpmforge rhel-debuginfo.repo rpmforge.repo


    ( I have installed rpmforge and atomic later. ) But hmmm! I see the problem now. In GUI "Add/Remove Software" is a list of repositories and Desktop is checked, but there is no file for it. How so? It should be by the default when my system is registered, right?

  9. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Check the contents of atomic.repo and rpmforge.repo files.
    Both repositories should be enabled.
    Code:
    enabled=1
    In case it doesn't work, post the contents of both files here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  10. #9
    Just Joined!
    Join Date
    Jun 2010
    Posts
    21
    Those are enabled and there is no problem with them. but RHEL Desktop does not. I can see it in Repository Manager GUI checked, but when I try to edit it, there is an exception:

    Component: pirut
    Summary: TB6761ebd5 posixpath.py:378:normpath:AttributeError: 'NoneType' object has no attribute 'startswith'

    Traceback (most recent call last):
    File "/usr/lib/python2.4/site-packages/pirut/RepoSelector.py", line 306, in _edit
    path = os.path.normpath(r.repofile)
    File "/usr/lib64/python2.4/posixpath.py", line 378, in normpath
    initial_slashes = path.startswith('/')
    AttributeError: 'NoneType' object has no attribute 'startswith'

    Local variables in innermost frame:
    path: None
    is this normal??? It is absolutely fresh install! Only thing installed were nvidia drivers

  11. #10
    Just Joined!
    Join Date
    Jun 2010
    Posts
    21

    Smile Solution!!

    In case, somebody will look for the same solution, there it is

    I have contacted Red Hat support and got an answer:

    Packet xorg-x11-server-sdk is available from flowing channels:

    Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)
    RHEL Desktop Workstation (v. 5 for 64-bit x86_64)

    Packet libXi-devel is available from flowing channels:

    Red Hat Enterprise Linux (v. 5 for 64-bit x86_64)
    RHEL Desktop Workstation (v. 5 for 64-bit x86_64)
    RHEL Extended Update Support (v. 5.4.z for 64-bit x86_64)
    So you need to be subscribed to some of these channels in order to get packet you need. Hope this help someone

    Cheers, Pidiclovek

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •