Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, I'm using fedora 8, the pc-speaker is not activated automatically. When I issue the command 'modprobe pcspkr', the module is loaded. I want this to be loaded during the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2010
    Posts
    3

    load module with modprobe.conf


    Hi,

    I'm using fedora 8, the pc-speaker is not activated automatically.

    When I issue the command 'modprobe pcspkr', the module is loaded. I want this to be loaded during the boot-procedure of the machine.

    I could ofcourse just execute this command on boot, but I want to resolve this issue on the "correct way".

    I looked in /etc/modprobe.d/blacklist, but I see no reference to the pc-speaker.

    I tried editing /etc/modprobe.conf, but I'm probably not using the correct syntax to load this module automatically.

    I added:

    alias pc-speaker pcspkr

    I tried searching on internet, but it's not clear what syntax to use, when I want to just add a module (without parameters).

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,452
    FC8 is, in internet terms, an "antique" system. We are currently up to FC13. Have you considered updating your OS? Current ones deal with this sort of stuff much more seamlessly, generally.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Agreed on upgrading to a supported version of Fedora, but to answer your question, you would put a line modprobe <module name> in /etc/rc.modules

    Code:
    su -
    echo "modprobe pcspkr" >> /etc/rc.modules
    EDIT: This file may not exist by default. The above will create it or you can create it yourself. Also, you can use the text editor of your choice to edit the file. And finally, you may need to set the executable flag
    Code:
    su -
    chmod +x /etc/rc.modules

  4. #4
    Just Joined!
    Join Date
    Sep 2010
    Posts
    3
    Quote Originally Posted by Rubberman View Post
    FC8 is, in internet terms, an "antique" system. We are currently up to FC13. Have you considered updating your OS? Current ones deal with this sort of stuff much more seamlessly, generally.
    I know, but this OS is installed at work here. The software written for it is only officially supported by Fedora 8. And support will only be delivered for fedora 8 as well...

  5. #5
    Just Joined!
    Join Date
    Sep 2010
    Posts
    3
    Quote Originally Posted by reed9 View Post
    Agreed on upgrading to a supported version of Fedora, but to answer your question, you would put a line modprobe <module name> in /etc/rc.modules

    Code:
    su -
    echo "modprobe pcspkr" >> /etc/rc.modules
    EDIT: This file may not exist by default. The above will create it or you can create it yourself. Also, you can use the text editor of your choice to edit the file. And finally, you may need to set the executable flag
    Code:
    su -
    chmod +x /etc/rc.modules
    Thanks.

    it works, but I found another solution online.

    Code:
    su - root
    echo 'modprobe pcspkr' > /etc/sysconfig/modules/pcspkr.modules
    chmod +x /etc/sysconfig/modules/pcspkr.modules
    Now, I don't know what is the best(standardized) method of doing this...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •