Find the answer to your Linux question:
Results 1 to 7 of 7
I just recently upgraded to Fedora Core 3 from FC 2. Everything works perfectly, except for my screensaver. I chose The Matrix, under the banners and pictures category. I have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Location
    Franklin, Tennessee
    Posts
    8

    Screen saver doesn't activate


    I just recently upgraded to Fedora Core 3 from FC 2. Everything works perfectly, except for my screensaver. I chose The Matrix, under the banners and pictures category. I have the time set to 3 minutes, with no power management enabled, but the screensaver still doesn't come on. My monitor goes black at the designated time that the screensaver was supposed to come on. Anyone have any idea how to help me?

  2. #2
    Linux Newbie rat007's Avatar
    Join Date
    Jul 2004
    Location
    Brno
    Posts
    230

    Re: Screen saver doesn't activate

    Aren't you using OpenGL version of Matrix ss? And is OpenGL working properly?

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Location
    Franklin, Tennessee
    Posts
    8
    No, it isn't the OpenGL version of the Matrix. It is the one under the Banners and Pictures category. Not the one under the OpenGL category.

  4. #4
    Just Joined!
    Join Date
    Dec 2004
    Posts
    3
    Quote Originally Posted by King P
    No, it isn't the OpenGL version of the Matrix. It is the one under the Banners and Pictures category. Not the one under the OpenGL category.
    Is there something up with OpenGL that would cause the screensaver to not activate?

  5. #5
    Just Joined!
    Join Date
    Nov 2004
    Location
    Downey Ca
    Posts
    70

    Fedora Core 3 Monitor Standby Work Around

    There sre three files that I edited.
    XOrg.conf
    XF98Config
    XF86Config.eg

    They are in /usr/X11R6/lib/Server/

    Look for

    Option "blank time" "10" # 10 minutes

    Option "standby time" "20"
    Option "suspend time" "30"
    Option "off time" "60"

    I changed mine to

    Option "blank time" "0" # 10 minutes

    Option "standby time" "0" # 20 minutes
    Option "suspend time" "0" # 30 minutes
    Option "off time" "0" # 60 minutes

    Then I went to the Control Center in KDE to the screensaver section and under setup unchecked the use OpenGL screensavers and Random Screensavers worked fine.

  6. #6
    Just Joined!
    Join Date
    Nov 2004
    Location
    Franklin, Tennessee
    Posts
    8

    Screensaver Woes

    I have since learned that the problem itself is within KDE. The linux Kernel uses the Xscreensaver function for all of it's screensavers. KDE and Gnome both have a "wrapper" that works around the XScreensaver function.

    A lot of people have complained of this same problem and the only they have been able to get it to work, is by going into the shell and typing

    xscreensaver &

    Then the settings for the Xscreensaver utility come up. You then have to configure it there. The only problem with this is that you have to go back into the shell and type the command everytime you restart your OS.

    That really blows. Gnome had no problems with the Screensaver, so it must be something within KDE.

    The newest release from KDE is a service release for all of the people that have had problems with the 3.3.1 and 3.3.2 versions. I believe the newest one is 3.3.4.

    Thanks for all of the responses

  7. #7
    Just Joined!
    Join Date
    Dec 2004
    Posts
    3

    Screen saver woes!!!!

    Tried xscreensaver & and got:
    xscreensaver &
    [1] 9860
    [root@Linux-Command ~]# Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    xscreensaver: Can't open display: :0
    xscreensaver: initial effective uid/gid was root/root (0/0)
    xscreensaver: running as nobody/nobody (99/99)

    xscreensaver: This is probably because you're logging in as root. You
    shouldn't log in as root: you should log in as a normal user,
    and then `su' as needed. If you insist on logging in as
    root, you will have to turn off X's security features before
    xscreensaver will work.

    Please read the manual and FAQ for more information:

    http://www.jwz.org/xscreensaver/faq.html
    http://www.jwz.org/xscreensaver/man.html


    [1]+ Exit 1 xscreensaver

    So I guess I need to do something else...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •