Find the answer to your Linux question:
Results 1 to 2 of 2
Hi... The website, intellinuxwireless -DOT- org says that the relevant kernel module drivers for devices like this laptop's Intel Centrino Advanced-N 6230AGN are the following (though that site doesn't explicitly ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    11

    Intel Centrino Advanced-N 6230AGN (need driver for this WiFi) ...



    Hi...

    The website, intellinuxwireless -DOT- org says that the relevant
    kernel module drivers for devices like this laptop's Intel Centrino Advanced-N 6230AGN
    are the following (though that site doesn't explicitly mention this exact device):

    root# locate iwlwifi
    /lib/modules/2.6.35.10-74.fc14.x86_64/kernel/drivers/net/wireless/iwlwifi/iwl3945.ko
    /lib/modules/2.6.35.10-74.fc14.x86_64/kernel/drivers/net/wireless/iwlwifi/iwlagn.ko
    /lib/modules/2.6.35.10-74.fc14.x86_64/kernel/drivers/net/wireless/iwlwifi/iwlcore.ko

    An "lspci -k" doesn't show any of these bound to this hardware device (which, again,
    is a Intel Centrino Advanced-N 6230AGN device). See here....

    root# lspci -k

    03:00.0 Ethernet controller: JMC250 PCI Express Gigabit Ethernet Controller (rev 05)
    Subsystem: CLEVO/KAPOK Computer Device 7100
    Kernel driver in use: jme <--- GOOD for the Ethernet device
    Kernel modules: jme <--- GOOD

    01:00.0 VGA compatible controller: nVidia Corporation Device 0e31 (rev a1)
    Subsystem: CLEVO/KAPOK Computer Device 7100
    Kernel driver in use: nvidia <--- GOOD or the video controller.
    Kernel modules: nvidia, nouveau, nvidiafb <--- GOOD

    04:00.0 Network controller: Intel Corporation Centrino Advanced-N 6230 (rev 34)
    Subsystem: Intel Corporation Centrino Advanced-N 6230 AGN
    Kernel driver in use: <---- missing here NO GOOD! NOTHING FOR THE WiFI Device.
    Kernel modules: <---- missing here NO GOOD

    This is true even after I do a "modeprobe iwlagn" (etc.)

    It looks like we need a driver for this. I've written the folks at "ilw -AT- linux.intel -DOT- com",
    but no response.

    What to do?

    Thanks,
    Noel

  2. #2
    Just Joined!
    Join Date
    Jan 2009
    Posts
    11

    SOLVED: Intel Centrino Advanced-N 6230AGN (need driver for this WiFi)

    I tried two things to solve this.

    (1) One of the linux-wireless developers alerted me to the compat-wireless project located at
    "wireless.kernel -DOT- org/en/users/Download".

    This is where you can download the latest code for kernel module drivers having anything
    to do with the wireless subsystem in linux (i.e. linux drivers for your wireless hardware). This
    is latest code that is destined for the linux kernel (and in some cases have already been
    integrated into it). The instructions for how to compile and integrate this into your currently
    running kernel is pretty clearly described in the above URL, should your stock wireless drivers
    not work for you - as was the case with me. Although this technique did not work for me, it was simply because my kernel (the Fedora kernel itself - not the drivers I tried to integrate into it
    from the compat-wireless site - was too old for my very bleeding-edge hardware). This will in
    work and work well in most cases!!! Try it.

    (2) This worked for me... After downloading and compiling kernel version 2.6.38-rc4
    (latest at the time of this writing at kernel.org), I was finally able to get "wlan0"
    up via the included "iwlagn.ko (etc)" driver, as confirmed by "ethtool -i
    wlan0".

    When the hardware is too new (cutting edge), you need to download the
    latest kernel and compile it yourself. Doing a "yum update kernel" (etc), is not enough because
    Fedora's release schedule would not necessarily have the latest enabling enhancements
    and fixes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •