Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I'm trying now to compile a Linux Fedora Core 2 kernel, and the boot fails with the following: ds:no socket drivers loaded! kmod: failed to exec /sbin/modprobe -s -k ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    6

    Cannot create a bootable Fedora Core 2 kernel


    Hi,

    I'm trying now to compile a Linux Fedora Core 2 kernel, and the boot fails with the following:

    ds:no socket drivers loaded!
    kmod: failed to exec /sbin/modprobe -s -k block-major-8, errno = 2
    VFS: Cannot open root device "sda2" or 08:02
    Pleas append a correct "root=" boot option
    Kernal panic: VFS :Unable to mount root fs on 08:02

    1. I searched extensively on the internet, but could not find which item in 'make xconfig' enables the "ds/socket drivers"
    2. My root filesystem is on /dev/sda2 (/boot is on /dev/sda1): I tried both these entries on the kernel line of grub.conf, but both give similar errors.

    Since I suspected the problem is connected to the SCSI drivers, I chose in 'make xconfig' everything in the SCSI section, but the kernel still fails the boot with the same errors as above.

    Have you any ideas how can I make this kernel a bootable kernel ?

    Thanks,
    Ron.

    P.S.:
    I built the above mentioned kernel doing the following:

    make mrproper

    I then copied the config file from "/usr/src/linux-2.4.21-20.EL/configs/kernel-2.4.21-i686.config" to ".config" and then

    make xconfig
    make dep
    make clean
    make bzImage
    make modules
    make modules_install
    make install

    And the last line, in addition to installing the kernel files in the /boot directory, also executes the /sbin/new-kernel-pkg script that builds a new initrd image and adds new entries to the boot loader configuration file.

    Indeed, a .img was created and was put in the correct initrd line of grub.conf (the current kernel .img size is ~300K, while the .img of the kernel I built is ~170K).

    My original kernel work Okay.

    I tried compiling the kernel using "make oldconfig", and got the exact same problems.

  2. #2
    Linux Newbie
    Join Date
    Jul 2004
    Location
    WA, USA
    Posts
    102
    Did you build filesystem support into the kernel, instead of loading it as a module?

    Robert Peaslee
    Taking a walk on the wonderful path computers have lain before me

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    6
    Quote Originally Posted by PeasleeR
    Did you build filesystem support into the kernel, instead of loading it as a module?

    Robert Peaslee
    Hi Robert,
    Yes, all ext3 items in "make xconfig" are included into the kernel, not as modules.
    Bye,
    Ron.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •