Find the answer to your Linux question:
Results 1 to 4 of 4
Hi Guys, I've got a HackStrike network appliance - with RedHat Nash Installed. It seems that since I did not use this device ages ago, the root password is forgotten. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2011
    Posts
    3

    RedHat Appliance - Root Password


    Hi Guys,

    I've got a HackStrike network appliance - with RedHat Nash Installed.

    It seems that since I did not use this device ages ago, the root password is forgotten. I've booted up with a Linux Live CD and mounted the internal disk of this appliance. The passwd file shows a couple of users I've created - and when I've tried to login with them on serial rs232 - It gives me this output:

    Password:
    Last login: Sat Feb 12 11:11:27 on ttyS0
    You ha
    HackStrike Fortress 1 console

    Sends me back to Login prompt, it seems that this user does not have access to console mode - however i cannot remember the root password.

    when I've tried to edit the shaddow file it gives me permission denied ( with the hard disk mounted on Linux Live CD)

    and tips how I can recover this root password?

    Regards

    ollie

  2. #2
    Just Joined!
    Join Date
    Jun 2010
    Posts
    8
    I know the way that needs to be booted by a live cd which you have done already and mount the partition you have on your hard disk.

    then edit the /etc/shadow, clear the password of root and save.

    If you have booted from a live CD, there should not be any restriction to access the mounted hard disk because you are running on LIve CD not on the hard disk.

    Am I making a sense?

  3. #3
    Just Joined!
    Join Date
    Feb 2011
    Posts
    3
    Thats what I'm trying to do, however when i nano the shadow file - it gives me permission denied - checked the rights , and its true i havent got read or write access.... i could chmod however i dont want to ruin this....

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2011
    Posts
    3
    UPDATE:

    I can edit the shadow file, it was just something related with the permission.... however my concern is... if i do update a RedHat Nash 3.something shadow generated password with Ubuntu 10 generated password... will that still work?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •