Find the answer to your Linux question:
Results 1 to 6 of 6
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Need help updating RH 7.0 Server


    I really need some help fixing up my server. I recently had it brought to my attention that I need to fix some issues before I can get approved by my merchant company.

    I am running Redhat 7.0, and I need to update these programs to make my server secure.

    I have OpenSSH 3.1p1-6
    modssl 2.8.12

    RPM says i have php 4.2.2 and php says I have 5.0.1

    Anyways I need to update all of these programs to the latest releases, but they all have so many dependancies I feel like it would take me all day, and even then I feel like I would have wasted alot of time.

    When i tried to update OpenSSH through RPM it told me I needed Glibc 2.3 and that there wwere a whole bunch of failed dependancies... do I have to take care of all of these or is there a simpler way to do this? Glibc 2.3 also told me I had more failed dependancies... I'm worried that every program is going to have failed dependancies and I'm going to have to track down every program it's going to take forever...

    What am I doing wrong?

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    St. Petersburg, FL
    well, you could try using yum, which comes with redhat. (type: "man yum")
    or, if you want to try the better, in my opinion, APT, google "apt for rpm".
    both of these package managing programs resolve dependencies for you, and download the package file as well as any dependencies for you from the internet.
    (or, if you don't like either of those two solutions, visit they have an ENORMOUS rpm database for nearly an package/dependency you could think of.)

  3. #3
    thanks so much,

    I will definately give this a try.

    I thought it was because I am running RH 7.0 and not 9.0 that I would have to basically do all the upgrades manually.

    Thanks for ur help!

  4. $spacer_open
  5. #4
    Ok so apparantly I have RH 7.3

    Here's what happens when I tried what you said.

    bash-2.05a# rpm -i
    error: failed dependencies:
    rpm >= 4.1.1 is needed by
    libxml2-python is needed by

    I tried to update RPM but it had like 20+ failed dependancies
    so I decided to try APT

    bash-2.05a# rpm -i apt-0.5.5cnc6-fr0.rh70.1.i386.rpm
    error: failed dependencies: is needed by apt-0.5.5cnc6-fr0.rh70.1 is needed by apt-0.5.5cnc6-fr0.rh70.1 is needed by apt-0.5.5cnc6-fr0.rh70.1

    I'm so lost right now and it doesn't seem like I'm making any progress at all.

  6. #5
    Just Joined!
    Join Date
    Jun 2004
    London, UK
    I would honestly recommend that you backup your data and do a full reinstall of the machine. RH7.3 is quite ancient and patching it again and again will be a tru pain.

    Note sure if FC3 is your best choice but it will definatly solve your problems.

  7. #6
    Linux Enthusiast
    Join Date
    Jun 2002
    San Antonio
    Okay, if you are looking at using this server to do business transactions such as credit cards, etc. I would _highly_ suggest moving to RedHat ES2.1. It still has security patches being released, and is quite stable. I work on a number of ES2.1 machines at my place of employment, and they are so similar to 7.3 it isn't worth mentioning.

    However, there are some caveats. You will have to migrate your data. You will have to install ensim again (or have whoever did it in the first place do it again). You will have to recompile PHP 5.0.2 (5.0.1 is just a bit old, and I would recommend 5.0.2 if you need the functionality of 5.x).

    hali is right when he says 7.3 is ancient. Your credit card company is right in not giving you a merchant account until you close those holes.


    I respectfully decline the invitation to join your delusion.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts