Find the answer to your Linux question:
Results 1 to 9 of 9
I've looked through numerous xf86config-related posts in this forum but haven't quite found anything like I'm experiencing... I'm running RH 9 on a linuxcertified lc2210 laptop with a native 1024x768 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Location
    Rome, Italy
    Posts
    10

    Help needed with XF86Config


    I've looked through numerous xf86config-related posts in this forum but haven't quite found anything like I'm experiencing...

    I'm running RH 9 on a linuxcertified lc2210 laptop with a native 1024x768 resolution for the 15" laptop screen and XFree86 4.4.0. Now I got a 17" LG L1730 LCD that I plug in to the laptop's 15-pin monitor plug. The pictures is awesome, but the 17" screen's native resolution is 1280x1024, so I've tried to get this changed, which is where the problem starts...

    I've tried the following, all to no avail:

    - Change /etc/X11/XF86Config to reflect a different Monitor0 and different resolution options in the Screen0 subsection;
    - Use redhat-config-xfree86 to adjust resolution and monitor;
    - remove /etc/X11/XF86Config altogether

    The last one is particularly puzzling - I removed the XF86Config (I have no other XF86Config in any of the locations the man mentions)!

    Can it be that the configuration options for monitor, screen resolution, etc. are hardwired somewhere else?

    How can I get my LCD to show at 1280x1024 (multi-monitor options seem out of the question because my laptop only has one graphic card).

    Thanks for any and all help

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    Can't you just use the display configuration tool?
    If XFree86 is using a non-standard config, check the logs for which file it's using.
    Emotions are the key to the soul.
    Registered Linux User #375050

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Location
    Rome, Italy
    Posts
    10
    Changes made in the display configuration tool for some reason don't have any impact after restarting X.

    Which logs would i check to find out which config file XFree86 is using?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2004
    Posts
    15
    The log files are located in /var/log

    The X server log files are something like XFree86.log Take a look at this file and maybe it will give a clue on what needs to be modified.

    Errors are indicated with (EE) at the beginning of the line.

    Additionally, there is something more that you can try. Before trying this, try and get updated drivers for your video card installed on Linux. Please backup your XF86Config file before doing this:


    Open the XF86Config file and then check for the following:


    Under:

    Section "Monitor"
    Ensure that the lines:

    HorizSync
    VertRefresh

    have the correct horizontal and vertical refresh rate values. You can get these values from the monitor manual.

    It should be something like:

    HorizSync 30-70
    VertRefresh 60-120


    Additionally, find the following line in XF86Config:

    Subsection "Display"

    This should be somewhere near the end of the file

    This has entries like:

    Depth 24
    Modes "1024x768" "800x600"


    The first entry under the "Modes" option is what is used as the default resolution. So, set this to 1280x1024 and save the file.

    It should look something similar to:

    Subsection "Display"
    Depth 24
    Modes "1280x1024" "1024x768" "800x600"


    Restart the X server after saving the changes made to the file and check if the monitor renders the resolution that you want.

    Please keep me posted on what happens.

  6. #5
    Just Joined!
    Join Date
    Nov 2004
    Location
    Rome, Italy
    Posts
    10
    Thanks for the suggestions, petrafied. I checked /var/log/XFree86.0.log. There are no error lines (EE) but a number of warnings (WW):

    (WW) Open APM failed (/dev/apm_bios) (No such device)
    (WW) I810(0): Extended BIOS function 0x5f11 not supported.
    (WW) I810(0): Bad V_BIOS checksum

    I don't know what these mean

    I've tried what you recommend, although the "Display" subsection appears in my "Screen" section, not the "Monitor" section does it really need to go in the "Monitor" Section?). I'm still stuck with 1024x768.

    I think the problem may be that 1024 x 768 as the highest resolution for my laptop dispaly is hardwired and can't be changed.

    So I probably need to define a separate "Screen1" and configure it to display under xinerama (add something like Identifier "Screen1" RightOf "Screen0" in the ServerLayout Section). I read somewhere that in this way you can get the laptop to use the VGA outlet for an independent display, rather than just a mirror of the laptop dispaly, as you would for powerpoint presentations with a projector.

    Any further suggestions are most welcome!

  7. #6
    Just Joined!
    Join Date
    Dec 2004
    Posts
    15
    Thanks for the update.

    About going into the monitor section. I think it does need to go into that section. Just try changing the settings and check if it helps.

    You can re-configure X by using this command in the shell prompt before you start the X server.

    XFree86 –configure

    This will basically write a new XF86 file in /etc/X11

    The warning messages do not seem to be a cause for concern. I found this info on the following forum:

    http://sourceforge.net/mailarchive/f...ewmonth=200306

    One more suggestion:

    Try using the Display manager to configure the monitor. I think that you can get into the X server. Once you do, click on K-> System Settings-> Display.Under the Advanced tab, click on Configure. Check if your monitor Model is listed under LG Electronics. Ideally it should be ( I found LG 1730 DM as an option on my system). Try setting this option and click on OK. Click on OK once again. It will prompt you to restart the X server.

    Check if this helps you to get your required screen resolution.

    If this does not help, let me know the laptop model and the video card. I will check if anything else could be a cause here.

    Hope that helps . Keep me posted.

  8. #7
    Just Joined!
    Join Date
    Nov 2004
    Location
    Rome, Italy
    Posts
    10
    I followed your suggestions but still can't get my external monitor to display in 1280x1024.

  9. #8
    Just Joined!
    Join Date
    Nov 2004
    Location
    Rome, Italy
    Posts
    10
    Got it working, sort of!

    I fiddled around with dual head settings I saw on the internet and now how have the external flat panel working at 1280x1024 (it's gorgeous!!!) - but the laptop display is off.

    Any idea what's causing this? Below's my /etc/X11/XF86Config

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen 0 "Screen0" 0 0
    InputDevice "Mouse0" "CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "DevInputMice" "AlwaysCore"
    Option "MonitorLayout" "LFP, DFP"
    EndSection

    Section "Files"

    # RgbPath is the location of the RGB database. Note, this is the name of the
    # file minus the extension (like ".txt" or ".db"). There is normally
    # no need to change the default.
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Red Hat 6.0 and later now use a font server independent of
    # the X server to render fonts.
    RgbPath "/usr/X11R6/lib/X11/rgb"
    FontPath "unix/:7100"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath "/usr/X11R6/lib/X11/fonts/local/"
    FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
    EndSection

    Section "Module"
    Load "dbe"
    Load "dri"
    Load "extmod"
    Load "fbdevhw"
    Load "freetype"
    Load "glx"
    Load "record"
    Load "type1"
    EndSection

    Section "InputDevice"

    # Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
    # Option "Xleds" "1 2 3"
    # To disable the XKEYBOARD extension, uncomment XkbDisable.
    # Option "XkbDisable"
    # To customise the XKB settings to suit your keyboard, modify the
    # lines below (which are the defaults). For example, for a non-U.S.
    # keyboard, you will probably want to use:
    # Option "XkbModel" "pc102"
    # If you have a US Microsoft Natural keyboard, you can use:
    # Option "XkbModel" "microsoft"
    #
    # Then to change the language, change the Layout setting.
    # For example, a german layout can be obtained with:
    # Option "XkbLayout" "de"
    # or:
    # Option "XkbLayout" "de"
    # Option "XkbVariant" "nodeadkeys"
    #
    # If you'd like to switch the positions of your capslock and
    # control keys, use:
    # Option "XkbOptions" "ctrl:swapcaps"
    # Or if you just want both to be control, use:
    # Option "XkbOptions" "ctrl:nocaps"
    #
    Identifier "Keyboard0"
    Driver "keyboard"
    Option "XkbRules" "xfree86"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "PS/2"
    Option "Device" "/dev/psaux"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "no"
    EndSection

    Section "InputDevice"

    # If the normal CorePointer mouse is not a USB mouse then
    # this input device can be used in AlwaysCore mode to let you
    # also use USB mice at the same time.
    Identifier "DevInputMice"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "no"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Monitor Vendor"
    ModelName "L1730S"
    HorizSync 30.0 - 83.0
    VertRefresh 56.0 - 75.0
    Option "dpms"
    EndSection

    Section "Monitor"
    Identifier "Monitor1"
    VendorName "LG"
    ModelName "L1730S"
    HorizSync 30.0 - 83.0
    VertRefresh 56.0 - 75.0
    Option "dpms"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "i810"
    VendorName "Videocard vendor"
    BoardName "Intel 865"
    VideoRam 32768
    Option "MonitorLayout" "LFP,CRT"
    EndSection

    Section "Screen"

    # SubSection "Display"
    # Depth 24
    # Modes "1024x768" "800x600" "640x480"
    # EndSubSection
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 16
    SubSection "Display"
    Depth 16
    Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    EndSection

    Section "Screen"

    # SubSection "Display"
    # Depth 24
    # Modes "1024x768" "800x600" "640x480"
    # EndSubSection
    Identifier "Screen1"
    Device "Videocard0"
    Monitor "Monitor1"
    DefaultDepth 16
    SubSection "Display"
    Depth 16
    Modes "1280x1024"
    EndSubSection
    EndSection

    Section "DRI"
    Group 0
    Mode 0666
    EndSection

  10. #9
    Just Joined!
    Join Date
    Dec 2004
    Posts
    15
    Great to know that the monitor has been configured.

    It looks like the drivers on Linux are the default ones. This usually has very limited functionality as far as I have noticed on my Radeon card.

    It is very likely that the limitations in the existing driver are a cause here.

    Try installing the drivers provided by Intel for your graphics card and check if they help.

    They should be able to provide additional functionality for configuring the system for use with multiple monitors.

    You can try downloading the appropriate driver from the following website:

    http://downloadfinder.intel.com/scri...port_download&

    Let me know if installing these drivers helped to configure the display as needed.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •