Find the answer to your Linux question:
Results 1 to 8 of 8
I downloaded the demo for RHEL Server 6. I'd like to get Xwindows going, but have been thwarted thus far. I have no real Linux experience, but I have been ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2010
    Posts
    8

    [SOLVED] Getting Xwindows to Run RHEL Server 6


    I downloaded the demo for RHEL Server 6. I'd like to get Xwindows going, but have been thwarted thus far.

    I have no real Linux experience, but I have been toying around with some suggestions already posted.

    The last suggestion that I tried was to edit /etc/inittab file and change the value from 3 to 5. That didnt' work.

    There's an X11 directory with a file called 'prefdm' that has a bunch of code in it that I have no idea what it means.

    Can anyone shed some light on how to get X windows to start?

  2. #2
    Linux Enthusiast meton_magis's Avatar
    Join Date
    Oct 2006
    Location
    arizona
    Posts
    699
    from the command line when you're logged in, you should be able to just run

    startx

    and it will start. That is assuming you installed with the graphical options installed. The windowing system IS optional, so it may not have installed, especially if you selected a server build and not a desktop (workstation ) install option.
    New to the internet, technical forums, or the hacker / open source community??
    Read this to learn good posting habits http://www.catb.org/~esr/faqs/smart-questions.html

    RHCE for RHEL version 5
    RHCT for RHEL version 4

  3. #3
    Just Joined!
    Join Date
    Aug 2010
    Posts
    8
    Quote Originally Posted by meton_magis View Post
    from the command line when you're logged in, you should be able to just run

    startx

    and it will start. That is assuming you installed with the graphical options installed. The windowing system IS optional, so it may not have installed, especially if you selected a server build and not a desktop (workstation ) install option.
    Yes, I tried that and it just said, 'command not found'

    How does one go about installing the x windows from the DVD from the cmd line?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2010
    Posts
    8
    I just successfully installed X Windows guys, so it does look like X Windows supported for RHEL Server.

    (I even got it to reboot after the install was complete, created a user name, setup the time/date and clicked finish.) It rebooted again after this configuration was complete.


    NOW, it comes up in txt mode only, it won't go into X Windows/GNOME anymore. I execture 'startx' (as root or a normal user) and get this:


    Code:
    [root@redhat etc]# startx
    
    hostname: Host name lookup failure
    xauth:  creating new authority file /root/.serverauth.6816
    
    
    X.Org X Server 1.7.7
    Release Date: 2010-05-04
    X Protocol Version 11, Revision 0
    Build Operating System: x86-006 2.6.18-194.26.1.el5
    Current Operating System: Linux redhat 2.6.32-71.24.1.el6.x86_64 #1 SMP Sat Mar 26 16:05:19 EDT 2011 x86_64
    Kernel command line: ro root=/dev/mapper/vg_redhat-lv_root rd_LVM_LV=vg_redhat/lv_root rd_LVM_LV=vg_redhat/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us crashkernel=128M rhgb quiet
    Build Date: 23 February 2011  07:36:44PM
    Build ID: xorg-x11-server 1.7.7-26.el6_0.3
    Current version of pixman: 0.18.4
            Before reporting problems, check h||ps://redhat.com/apps/support/
            to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
            (++) from command line, (!!) notice, (II) informational,
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Mon May  2 13:49:31 2011
    (==) Using default built-in configuration (30 lines)
    (II) [KMS] Kernel modesetting enabled.
    
    waiting for X server to shut down
    
    [root@redhat etc]#

    Here's the last little bit of the log file:

    Code:
    (II) RADEON(0): Monitor name: Smart Cable
    (II) RADEON(0): EDID (in hex):
    (II) RADEON(0):         00ffffffffffff0006cf000000000000
    (II) RADEON(0):         000d01036e0000960eee91a3544c9926
    (II) RADEON(0):         0f5054ffff008180814f8140714f714a
    (II) RADEON(0):         71400101010164190040410026301888
    (II) RADEON(0):         3600000000000018bc34009851002a40
    (II) RADEON(0):         10901300000000000018000000fd0028
    (II) RADEON(0):         641e5f15000a202020202020000000fc
    (II) RADEON(0):         00536d617274204361626c650a2000c1
    (II) RADEON(0): EDID vendor "AVO", prod id 0
    (II) RADEON(0): Using EDID range info for horizontal sync
    (II) RADEON(0): Using EDID range info for vertical refresh
    (II) RADEON(0): Printing DDC gathered Modelines:
    (II) RADEON(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
    (II) RADEON(0): Modeline "1280x1024"x0.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 -hsync -vsync (80.0 kHz)
    (II) RADEON(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
    (II) RADEON(0): Modeline "800x600"x0.0   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
    (II) RADEON(0): Modeline "640x480"x0.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz)
    (II) RADEON(0): Modeline "640x480"x0.0   31.50  640 664 704 832  480 489 492 520 -hsync -vsync (37.9 kHz)
    (II) RADEON(0): Modeline "640x480"x0.0   30.24  640 704 768 864  480 483 486 525 -hsync -vsync (35.0 kHz)
    (II) RADEON(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
    (II) RADEON(0): Modeline "720x400"x0.0   35.50  720 738 846 900  400 421 423 449 -hsync -vsync (39.4 kHz)
    (II) RADEON(0): Modeline "720x400"x0.0   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz)
    (II) RADEON(0): Modeline "1280x1024"x0.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz)
    (II) RADEON(0): Modeline "1024x768"x0.0   78.75  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.0 kHz)
    (II) RADEON(0): Modeline "1024x768"x0.0   75.00  1024 1048 1184 1328  768 771 777 806 -hsync -vsync (56.5 kHz)
    (II) RADEON(0): Modeline "1024x768"x0.0   44.90  1024 1032 1208 1264  768 768 772 817 interlace +hsync +vsync (35.5 kHz)
    (II) RADEON(0): Modeline "832x624"x0.0   57.28  832 864 928 1152  624 625 628 667 -hsync -vsync (49.7 kHz)
    (II) RADEON(0): Modeline "800x600"x0.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz)
    (II) RADEON(0): Modeline "800x600"x0.0   50.00  800 856 976 1040  600 637 643 666 +hsync +vsync (48.1 kHz)
    (II) RADEON(0): Modeline "1280x1024"x0.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz)
    (II) RADEON(0): Modeline "1280x960"x75.0  129.86  1280 1368 1504 1728  960 961 964 1002 -hsync +vsync (75.1 kHz)
    (II) RADEON(0): Modeline "1280x960"x0.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz)
    (II) RADEON(0): Modeline "1152x864"x0.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz)
    (II) RADEON(0): Modeline "1152x864"x70.0   96.77  1152 1224 1344 1536  864 865 868 900 -hsync +vsync (63.0 kHz)
    (II) RADEON(0): Modeline "1152x864"x60.0   81.62  1152 1216 1336 1520  864 865 868 895 -hsync +vsync (53.7 kHz)
    (II) RADEON(0): Printing probed modes for output VGA-0
    (II) RADEON(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
    (II) RADEON(0): Modeline "1280x1024"x75.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz)
    (II) RADEON(0): Modeline "1280x1024"x75.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 -hsync -vsync (80.0 kHz)
    (II) RADEON(0): Modeline "1280x1024"x60.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz)
    (II) RADEON(0): Modeline "1280x960"x75.0  129.94  1280 1368 1504 1728  960 961 964 1002 -hsync +vsync (75.2 kHz)
    (II) RADEON(0): Modeline "1280x960"x60.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz)
    (II) RADEON(0): Modeline "1152x864"x75.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz)
    (II) RADEON(0): Modeline "1152x864"x70.0   96.73  1152 1224 1344 1536  864 865 868 900 -hsync +vsync (63.0 kHz)
    (II) RADEON(0): Modeline "1152x864"x60.0   81.58  1152 1216 1336 1520  864 865 868 895 -hsync +vsync (53.7 kHz)
    (II) RADEON(0): Modeline "1024x768"x75.1   78.80  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.1 kHz)
    (II) RADEON(0): Modeline "1024x768"x70.1   75.00  1024 1048 1184 1328  768 771 777 806 -hsync -vsync (56.5 kHz)
    (II) RADEON(0): Modeline "832x624"x74.6   57.28  832 864 928 1152  624 625 628 667 -hsync -vsync (49.7 kHz)
    (II) RADEON(0): Modeline "800x600"x72.2   50.00  800 856 976 1040  600 637 643 666 +hsync +vsync (48.1 kHz)
    (II) RADEON(0): Modeline "800x600"x75.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz)
    (II) RADEON(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
    (II) RADEON(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
    (II) RADEON(0): Modeline "640x480"x72.8   31.50  640 664 704 832  480 489 491 520 -hsync -vsync (37.9 kHz)
    (II) RADEON(0): Modeline "640x480"x75.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz)
    (II) RADEON(0): Modeline "640x480"x66.7   30.24  640 704 768 864  480 483 486 525 -hsync -vsync (35.0 kHz)
    (II) RADEON(0): Modeline "640x480"x60.0   25.20  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
    (II) RADEON(0): Modeline "720x400"x87.8   35.50  720 738 846 900  400 421 423 449 -hsync -vsync (39.4 kHz)
    (II) RADEON(0): Modeline "720x400"x70.1   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz)
    (II) RADEON(0): EDID for output VGA-1
    (II) RADEON(0): EDID for output DVI-0
    (II) RADEON(0): Output VGA-0 connected
    (II) RADEON(0): Output VGA-1 disconnected
    (II) RADEON(0): Output DVI-0 disconnected
    (II) RADEON(0): Using exact sizes for initial modes
    (II) RADEON(0): Output VGA-0 using initial mode 1024x768 +0+0
    (II) RADEON(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
    (II) RADEON(0): mem size init: gart size :1fdff000 vram size: s:1000000 visible:f00000
    (II) RADEON(0): EXA: Driver will not allow EXA pixmaps in VRAM
    (==) RADEON(0): DPI set to (96, 96)
    (II) Loading sub module "fb"
    (II) LoadModule: "fb"
    (II) Loading /usr/lib64/xorg/modules/libfb.so
    (II) Module fb: vendor="X.Org Foundation"
            compiled for 1.7.7, module version = 1.0.0
            ABI class: X.Org ANSI C Emulation, version 0.4
    (II) Loading sub module "ramdac"
    (II) LoadModule: "ramdac"
    (II) Module "ramdac" already built-in
    (II) Loading sub module "exa"
    (II) LoadModule: "exa"
    (II) Loading /usr/lib64/xorg/modules/libexa.so
    (II) Module exa: vendor="X.Org Foundation"
            compiled for 1.7.7, module version = 2.5.0
            ABI class: X.Org Video Driver, version 6.0
    (II) UnloadModule: "vesa"
    (II) Unloading /usr/lib64/xorg/modules/drivers/vesa_drv.so
    (II) UnloadModule: "fbdev"
    (II) Unloading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
    (II) UnloadModule: "fbdevhw"
    (II) Unloading /usr/lib64/xorg/modules/linux/libfbdevhw.so
    (--) Depth 24 pixmap format is 32 bpp
    (II) RADEON(0): [DRI2] Setup complete
    (II) RADEON(0): Front buffer size: 3072K
    (II) RADEON(0): VRAM usage limit set to 11059K
    (==) RADEON(0): Backing store disabled
    (II) RADEON(0): Direct rendering enabled
    (II) RADEON(0): Render acceleration enabled for R100 type cards.
    (II) RADEON(0): Setting EXA maxPitchBytes
    (II) EXA(0): Driver allocated offscreen pixmaps
    (II) EXA(0): Driver registered support for the following operations:
    (II)         Solid
    (II)         Copy
    (II)         Composite (RENDER acceleration)
    (II)         UploadToScreen
    (II)         DownloadFromScreen
    (II) RADEON(0): Acceleration enabled
    (==) RADEON(0): DPMS enabled
    (==) RADEON(0): Silken mouse enabled
    (II) RADEON(0): Set up textured video
    (II) RADEON(0): RandR 1.2 enabled, ignore the following RandR disabled message.
    (--) RandR disabled
    (II) Initializing built-in extension Generic Event Extension
    (II) Initializing built-in extension SHAPE
    (II) Initializing built-in extension MIT-SHM
    (II) Initializing built-in extension XInputExtension
    (II) Initializing built-in extension XTEST
    (II) Initializing built-in extension BIG-REQUESTS
    (II) Initializing built-in extension SYNC
    (II) Initializing built-in extension XKEYBOARD
    (II) Initializing built-in extension XC-MISC
    (II) Initializing built-in extension XINERAMA
    (II) Initializing built-in extension XFIXES
    (II) Initializing built-in extension RENDER
    (II) Initializing built-in extension RANDR
    (II) Initializing built-in extension COMPOSITE
    (II) Initializing built-in extension DAMAGE
    (II) SELinux: Disabled by boolean
    (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
    (II) AIGLX: enabled GLX_SGI_make_current_read
    (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
    (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
    (II) AIGLX: Loaded and initialized /usr/lib64/dri/radeon_dri.so
    (II) GLX: Initialized DRI2 GL provider for screen 0
    (II) RADEON(0): Setting screen physical size to 270 x 203
    (II) config/hal: Adding input device ImExPS/2 Generic Explorer Mouse
    (II) LoadModule: "evdev"
    (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
    (II) Module evdev: vendor="X.Org Foundation"
            compiled for 1.7.7, module version = 2.3.2
            Module class: X.Org XInput Driver
            ABI class: X.Org XInput driver, version 7.0
    (**) ImExPS/2 Generic Explorer Mouse: always reports core events
    (**) ImExPS/2 Generic Explorer Mouse: Device: "/dev/input/event3"
    (II) ImExPS/2 Generic Explorer Mouse: Found 9 mouse buttons
    (II) ImExPS/2 Generic Explorer Mouse: Found scroll wheel(s)
    (II) ImExPS/2 Generic Explorer Mouse: Found relative axes
    (II) ImExPS/2 Generic Explorer Mouse: Found x and y relative axes
    (II) ImExPS/2 Generic Explorer Mouse: Configuring as mouse
    (**) ImExPS/2 Generic Explorer Mouse: YAxisMapping: buttons 4 and 5
    (**) ImExPS/2 Generic Explorer Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    (II) XINPUT: Adding extended input device "ImExPS/2 Generic Explorer Mouse" (type: MOUSE)
    (**) ImExPS/2 Generic Explorer Mouse: (accel) keeping acceleration scheme 1
    (**) ImExPS/2 Generic Explorer Mouse: (accel) acceleration profile 0
    (II) ImExPS/2 Generic Explorer Mouse: initialized for relative axes.
    (II) config/hal: Adding input device AT Translated Set 2 keyboard
    (**) AT Translated Set 2 keyboard: always reports core events
    (**) AT Translated Set 2 keyboard: Device: "/dev/input/event2"
    (II) AT Translated Set 2 keyboard: Found keys
    (II) AT Translated Set 2 keyboard: Configuring as keyboard
    (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
    (**) Option "xkb_rules" "evdev"
    (**) Option "xkb_model" "pc105+inet"
    (**) Option "xkb_layout" "us"
    (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    (II) config/hal: Adding input device Video Bus
    (**) Video Bus: always reports core events
    (**) Video Bus: Device: "/dev/input/event4"
    (II) Video Bus: Found keys
    (II) Video Bus: Configuring as keyboard
    (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
    (**) Option "xkb_rules" "evdev"
    (**) Option "xkb_model" "pc105+inet"
    (**) Option "xkb_layout" "us"
    (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    (II) config/hal: Adding input device Power Button
    (**) Power Button: always reports core events
    (**) Power Button: Device: "/dev/input/event0"
    (II) Power Button: Found keys
    (II) Power Button: Configuring as keyboard
    (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
    (**) Option "xkb_rules" "evdev"
    (**) Option "xkb_model" "pc105+inet"
    (**) Option "xkb_layout" "us"
    (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    (II) config/hal: Adding input device Macintosh mouse button emulation
    (**) Macintosh mouse button emulation: always reports core events
    (**) Macintosh mouse button emulation: Device: "/dev/input/event1"
    (II) Macintosh mouse button emulation: Found 3 mouse buttons
    (II) Macintosh mouse button emulation: Found relative axes
    (II) Macintosh mouse button emulation: Found x and y relative axes
    (II) Macintosh mouse button emulation: Configuring as mouse
    (**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
    (**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    (II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
    (**) Macintosh mouse button emulation: (accel) keeping acceleration scheme 1
    (**) Macintosh mouse button emulation: (accel) acceleration profile 0
    (II) Macintosh mouse button emulation: initialized for relative axes.
    (II) ImExPS/2 Generic Explorer Mouse: Close
    (II) UnloadModule: "evdev"
    (II) AT Translated Set 2 keyboard: Close
    (II) UnloadModule: "evdev"
    (II) Video Bus: Close
    (II) UnloadModule: "evdev"
    (II) Power Button: Close
    (II) UnloadModule: "evdev"
    (II) Macintosh mouse button emulation: Close
    (II) UnloadModule: "evdev"
    [root@redhat log]#

  6. #5
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    its a really bad idea to startx as root, since your whole session will be as root

    probably you should generate an xorg.conf file using X -configure as root, then copy the file into /etc/X11/xorg.conf

  7. #6
    Just Joined!
    Join Date
    Aug 2010
    Posts
    8
    its a really bad idea to startx as root, since your whole session will be as root

    probably you should generate an xorg.conf file using X -configure as root, then copy the file into /etc/X11/xorg.conf
    Thanks for the suggestion. ^^^



    I'd still like to get the GNOME desktop environment installed. Here's the error that i'm getting:

    Code:
    [root@redhat ~]# yum groupinstall "GNOME Desktop Environment"
    Loaded plugins: rhnplugin
    Setting up Group Process
    Warning: Group GNOME Desktop Environment does not exist.
    No packages in any requested group available to install or update
    [root@redhat ~]#

  8. #7
    Linux Enthusiast meton_magis's Avatar
    Join Date
    Oct 2006
    Location
    arizona
    Posts
    699
    run

    yum grouplist

    one of the options will be something like GNOME Desktop. Copy that, and run

    yum groupinstall "GNOME Desktop"

    or whatever the full line is. Make sure to include the quotes if it is more than 1 word.

    You will need to be connected to the internet for this to work. I don't know how to do it off the cd/dvd
    Last edited by meton_magis; 05-03-2011 at 05:19 AM. Reason: internet
    New to the internet, technical forums, or the hacker / open source community??
    Read this to learn good posting habits http://www.catb.org/~esr/faqs/smart-questions.html

    RHCE for RHEL version 5
    RHCT for RHEL version 4

  9. #8
    Just Joined!
    Join Date
    Aug 2010
    Posts
    8
    Quote Originally Posted by meton_magis View Post
    run

    yum grouplist

    one of the options will be something like GNOME Desktop. Copy that, and run

    yum groupinstall "GNOME Desktop"

    or whatever the full line is. Make sure to include the quotes if it is more than 1 word.

    You will need to be connected to the internet for this to work. I don't know how to do it off the cd/dvd
    And that was it.. I did a:

    Code:
    yum groupinstall "Desktop" "Desktop Platform"
    ...and I now have the GNOME desktop on my RHEL 6 server.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •