Find the answer to your Linux question:
Results 1 to 6 of 6
hey guys I'm new to the forums so be nice, o and I've been using fedora for all of a week so be even nicer. Basically I have found a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2011
    Posts
    3

    Smile SAMBA issues


    hey guys

    I'm new to the forums so be nice, o and I've been using fedora for all of a week so be even nicer.

    Basically I have found a really old (15 years) computer which I am effectively using as an ethernet card for a 1.5 terabyte seagate external hard drive formatted in fat32. I have also been meaning to try linux and fedora for quite some time and thought why not do it on a computer I can break. Needless to say I have had a lot of fun and consulted the forum numerous times and they generally have fixed the problems, for which i owe you my thanks.

    however, there is one thing I am struggling with and just can't find the answer for, it is SAMBA. for some reason it has decided to not allow access to any computer outside of local. I have tried everything the forum has said

    umask -> can't find parameter in fstab
    force user -> for some reason still won't allow me in

    my smb.conf set up is as follows

    [global]
    workgroup = WORKGROUP
    server string = SambaServer
    security = share
    name resolve order = hosts lmhosts

    [Drive]
    path = /media/BACKUPFILES
    force user = Andrew
    force group = Andrew
    read only = no
    guest ok = yes

    I know it is incredibally insecure but that doesn't worry me I want quick access more than i want security the internal network is prity secure with just mine and my girlfriends computer

    I should probably mention it is sharing to both a MAC OS and Windows computer hence why I have to use SMB it is the one common denominator.

    I hope this is the right place to post this if not please direct me to where I should

    thanks in advance

  2. #2
    Just Joined!
    Join Date
    Feb 2007
    Location
    Cobleskill, NY
    Posts
    51
    Have you tried openfiler? It is a Linux system for drive sharing. It will do SAMBA/CIFS as well as NFS and iSCSI.
    You could also try freeNAS which is using a FreeBSD kernel.

  3. #3
    Just Joined!
    Join Date
    May 2011
    Posts
    3
    I'd rather avoid a reinstall since this has worked before but will keep that in mind as a last resort as it will probably work

    should probably mention as well that i can see the fedora computer and the shared folders on the other machines its just that when i click on the shared folders the macos and windows machine say path doesn't exist and no permissions respectively.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2010
    Posts
    4

    Problems with Samba

    Hi.

    I assume you have done things like create a user and samba account for all users added your users to the appropriate group and for the windows computer added yourself to the workgroup.

    I have found macs can be a bit temperamental with samba. You may need to GO connect and put in smb://yoursambaIP the shares may then start to show, also if things don't work try re-booting the mac this often does the trick.

    You could also add these lines to your {DRIVE] section in the samba config file and restart it.
    writable = yes
    write list = Andrew
    create mask = 2770
    directory mask = 2770
    # you may need the next line to see shares with the mac
    public = yes

    hope this helps

  6. #5
    Just Joined!
    Join Date
    Dec 2010
    Posts
    13
    I think the samba service is listening to your loopback interface.So to change it you can enter in your smb.conf
    "interfaces = name of the interface connected to lan"

    Regards,
    SS.

  7. #6
    Just Joined!
    Join Date
    May 2011
    Posts
    3
    ok ended up being a combination of problems. Had to turn of selinux properly (apparently I hadn't done it properly) and mount the drive with proper root permissions. hope this helps anyone else that has the same problem. but it now works properly in both mac and windows after a mac reboot

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •