Find the answer to your Linux question:
Results 1 to 3 of 3
I don't know why but Apache shows as failed (v1.33.3) in WHM server status. Steps: 1. Update apache 2. Update cPanel (release) 3. /scripts/upcp --focr 4. service chkservd restart 5. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    52

    URGENT: cpu over load, something wrong


    I don't know why but Apache shows as failed (v1.33.3) in WHM server status.

    Steps:

    1. Update apache
    2. Update cPanel (release)
    3. /scripts/upcp --focr
    4. service chkservd restart
    5. /scripts/updatenow
    6. Restart apache (fine, no errors)
    7. restart mysql (fine, no errors)

    Specs:
    Fedora Core 1
    CPanel Relase 160

    root@server [~]# /etc/rc.d/init.d/httpd configtest
    Syntax OK
    root@server [~]#

    Memory always floats about 68%
    server load always about 1.03 or higher

    I did a graceful reboot as well, problem arised again.

    The onl domain on the server is now not even loading AT ALL!
    DNS is 100% correct, fully propagated with registrar and all

    Resolvers are fine
    127.0.0.1 (local)
    and server IP for secondary

    What could I do?

    User Domain %CPU %MEM Mysql Processes
    zonaunde domain.net 1.13 73.23 0.1
    Top Process %CPU 6.4 /usr/bin/perl /usr/local/cpanel/3rdparty/bin/awstats.pl -configdomain.net -update
    Top Process %CPU 5.8 httpd [www.domain.net ] [/php/admin/index.php?paneright&sidafef72d9704fc80a827f891]
    Top Process %CPU 5.4 /usr/bin/perl /usr/local/cpanel/3rdparty/bin/awstats.pl -configdomain.net -update

  2. #2
    Just Joined!
    Join Date
    Oct 2004
    Posts
    52
    Response from level 2:

    myuser mydomain.net 1.12 73.04 0.1
    Top Process %CPU 6.4 /usr/bin/perl /usr/local/cpanel/3rdparty/bin/awstats.pl -configmydomain.net -update
    Top Process %CPU 5.8 httpd [www.mydomain.net] [/php/admin/index.php?paneright&sidafef72d9704fc80a827f891]
    Top Process %CPU 5.4 /usr/bin/perl /usr/local/cpanel/3rdparty/bin/awstats.pl -configmydomain.net -update
    mysql 0.37 10.68 0.0
    Top Process %CPU 50.0 /usr/sbin/mysqld --basedir/ --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/server.mydomain.net.pid --skip-locking
    Top Process %CPU 20.0 /usr/sbin/mysqld --basedir/ --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/server.mydomain.net.pid --skip-locking
    Top Process %CPU 19.0 /usr/sbin/mysqld --basedir/ --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/server.mydomain.net.pid --skip-locking
    root 0.36 9.09 2.0

    Kill off all the log analysis scripts for now and then rotate his logs as they are probally never been rolled over since day one and will get very large on a busy site. (cpanel has no log rotation by default). Once you do that then you will see the load drop down and performance come back up. The log analysis programs like AWStats, Urchin and Webalizer are all very CPU / IO intensive as they are chewing through large logs at times or need to do many thousands of reverse DNS lookups for every IP that has connected to the WWW server. That is why I suggested looking at the DNS first. If the DNS was set to 216.39.65.xx or other earlier today and you have not restarted the above webstats then that could have also been your problem from the start and the awstats above have just 'hung' and taking all your resources and just needs to be restarted.


    =
    Sorry, how do I kill off these processes and rotate logs? I've never done this before.

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    52
    Dont' know why, but when viewing a site it works with www but not without www, and below is the httpd.conf piece for this domain. Any ideas?

    The dns zone is fine, setup by cpanel default, not modified at all.

    <VirtualHost xxx.32.69.66>
    ServerAlias www.domain.net domain.net
    ServerAdmin webmaster@domain.net
    DocumentRoot /home/username/public_html
    BytesLog domlogs/domain.net-bytes_log
    ServerName www.domain.net
    ScriptAlias /cgi-bin/ /home/username/public_html/cgi-bin/
    <IfModule mod_userdir.c>
    Userdir disabled
    Userdir enabled username
    </IfModule>
    <IfModule mod_php4.c>
    php_admin_value open_basedir "/home/username:/usr/lib/php:/usr/local/lib/php:/tmp"
    </IfModule>
    User username
    Group username
    CustomLog domlogs/domain.net combined
    </VirtualHost>

    more status of apache overload:
    Process
    %CPU 63.0
    /usr/sbin/mysqld --basedir/ --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/server.domain.net.pid --skip-locking

    Top Process
    %CPU 55.0
    /usr/sbin/mysqld --basedir/ --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/server.domain.net.pid --skip-locking

    Top Process
    %CPU 34.0
    /usr/sbin/mysqld --basedir/ --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/server.domain.net.pid --skip-locking

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •