Find the answer to your Linux question:
Results 1 to 8 of 8
I am having trouble in FC3, setting the permissions for writing to two vfat filesystems for my standard account. As root I can read and write as I please, but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    9

    Read/Write Permission problems


    I am having trouble in FC3, setting the permissions for writing to two vfat filesystems for my standard account. As root I can read and write as I please, but as for my standard user account I cannot write to these partitions. As root I have attempted to change this but GNOME won't change these permissions at all and KDE(My preference), will change the permissions, but then will switch them back the next time I load my machine. I need to know how to fix this to where my standard account can read and write to the two vfat partitions.

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    change your /etc/fstab

    something like this needs to be present, this is from my fstab
    Code:
    /dev/hda4        /mnt/media       vfat        noauto,users,rw,exec  1   0

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    9
    I tried out that code line, but still the permission will not stick.
    I am beginning to believe that it is just a part of using a RedHat backed distribution, "We'll give you complete administrative power over your machine, if it serves OUR needs."

  4. #4
    Linux Newbie
    Join Date
    Oct 2004
    Posts
    133
    Is this an external drive?? if so, fstab-sync will rewrite the fstab entry for the drive every time you reboot, overwriting any costumizations you may have made. to remedy this, you have to turn off the service that does this. go to /etc/hal/device.d
    in this directory, you will find 50-fstab-sync.hal, which is a symbolic link. rename this file to 50-fstab-sync.hal.old, or something of the sort. now, make a new link that points to /bin/false, place it in /etc/hal/device.d, and name it 50-fstab-sync.hal

    This should prevent your settings from getting overwritten everytime you reboot.

  5. #5
    Linux Newbie imdeemvp's Avatar
    Join Date
    Sep 2004
    Location
    California
    Posts
    225
    This is the line in my fstab:
    Code:
    /dev/hdb2 /mnt/winfat32 vfat auto,users,rw,umask=0 0 0 0 0

    and i can read and write

  6. #6
    Just Joined!
    Join Date
    Nov 2004
    Posts
    9
    for mjman

    All of these partitions are on one hard drive, the main 40 GB in my notebook, as for changing the files that you are referring to, I don't believe that doing what you said would work. The permissions are not rewritten every time I boot, they are rewritten as soon as I set them.
    Like in KDE, I can make all of the changes that I want to, but as soon as I save them and I go back to view them, they are switched back. In GNOME the box is instantly switched back to the original setting.

  7. #7
    Just Joined!
    Join Date
    Nov 2004
    Posts
    9
    for imdeemvp

    The only thing from your command line that was different from what I had was the umask=0 0 0 0 0. I inserted this command and it worked thank you for your help with this particular problem.

  8. #8
    Linux Newbie imdeemvp's Avatar
    Join Date
    Sep 2004
    Location
    California
    Posts
    225
    No problema, we all ride the same penguin boat.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •