Find the answer to your Linux question:
Results 1 to 10 of 10
Can anyone help me out with thi error: Code: usr/bin/ld: cannot find -lblas collect2: ld returned 1 exit status scons: *** [libarac.so] Error 1...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2011
    Posts
    19

    Compiling error


    Can anyone help me out with thi error:

    Code:
    usr/bin/ld: cannot find -lblas                                                                                         
    collect2: ld returned 1 exit status                                                                                     
    scons: *** [libarac.so] Error 1

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    It appears as though the linker is looking for the blas library, whatever that is. What is your distro?

  3. #3
    Just Joined!
    Join Date
    Jun 2011
    Posts
    19
    what do you mean distro........please forgive me im new to linux

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Well, you are using a Red Hat or Fedora Linux distribution, I assume, b/c you posted in this forum. I guess I meant what version of the distribution are you running, e.g. Fedora 15, Red Hat Enterprise Server 5.2, etc.

    Do this to be sure:

    Code:
    grep -H . /etc/*-release

  5. #5
    Just Joined!
    Join Date
    Jun 2011
    Posts
    19
    Red Hat Enterprise Linux 5.4

  6. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    The package you want is blas-3.0-37.el5.i386.rpm (or thereabouts, version-wise). If you have the original installation media, you should find it there. Or if your RHN is set up, you should be able to 'yum install blas'.

    If neither is an option for you, you could always grab it from a CentOS/ScientificLinux repo, but that should be a last resort.

  7. #7
    Just Joined!
    Join Date
    Jun 2011
    Posts
    19
    I did a yum install blas it intalled 4 packages but I still get the same error

  8. #8
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    so if you do this command, you get something back, right?

    Code:
    /sbin/ldconfig -p|grep libblas
    I'm not sure why the linker is not finding it - as long as the blas library is in a standard place (e.g., /usr/lib), which i'm sure it is (mine is on my RHEL4 box anyway). Maybe you should explicitly tell the linker where the library is, something like:

    Code:
    gcc -o myprog -L/usr/lib  myprog.c
    maybe post the compiling command you are running (or the contents of your Makefile), and a gcc pro here can help you further.

  9. #9
    Just Joined!
    Join Date
    Jun 2011
    Posts
    19
    I get this when i execute this code:

    /sbin/ldconfig -p|grep libblas

    libblas.so.3 (libc6,x86-64) => /usr/lib64/atlas/libblas.so.3
    libblas.so.3 (libc6,x86-64) => /usr/lib64/libblas.so.3
    libblas.so.3 (libc6) => /usr/lib/libblas.so.3

  10. #10
    Just Joined!
    Join Date
    Jun 2011
    Posts
    19
    Im trying to install arac. https://github.com/bayerj/arac/wiki/installation

    after installin scons.........I run the command:

    $scons

    and the following error occurs.
    Code:

    usr/bin/ld: cannot find -lblas
    collect2: ld returned 1 exit status
    scons: *** [libarac.so] Error 1
    Last edited by Donasio; 06-16-2011 at 09:39 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •