Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, Recently, I am trying to use a complied software on Linux OS. I need to use X-Windows to do some initialize. When I run this software, I am getting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2011
    Posts
    3

    Update GLIBC on RHEL WS 4


    Hi,

    Recently, I am trying to use a complied software on Linux OS.
    I need to use X-Windows to do some initialize. When I run this software, I am getting the error:
    '/lib/tls/libc.so.6: version `GLIBC_2.4' not found'
    I also checked the version of GLIBC on my computer, the highest one is GLIBC_2.3.4. So I have to update my glibc to 2.4 or higher. Some tips said it can be done using yum. I am a new user for linux. Could anyone guide me to do that? Here is the information of my computer:
    Red Hat Enterprise Linux WS release 4 (Nahant Update ;
    Linux 2.6.9-89.0.3.ELsmp #1 SMP Sat Jun 13 07:02:28 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

    THANKS!

    BLUCE

  2. #2
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,392
    There is no easy way to have any other version than 2.3.x of glibc on redhat4.
    You might want to consider to reinstall with rh5 (2.5 and 2.3.4 compat) or rh6 (2.12 and 2.5 compat)
    You must always face the curtain with a bow.

  3. #3
    Just Joined!
    Join Date
    Jun 2011
    Posts
    3
    Thanks for your reply.
    Even the yum cannot do that?

  4. #4
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,392
    yum is a package manager, so it will (among other things) resolve dependencies, download packages and install them.
    But there are no 2.4 glibc packages for redhat 4 (at least not official ones).
    So there is nothing for yum to work with.

    The glibc is a very crucial package.
    I doubt, this "compiled software" (whatever it is) should be recompiled, if you really need it for rh4.
    But maybe a rh5/6 install is easier.

    By the way, check the other dependencies of that software before.
    Or better: Maybe there are pre-made RPMs for redhat5/6?
    You must always face the curtain with a bow.

  5. #5
    Just Joined!
    Join Date
    Jun 2011
    Posts
    3
    That means i have to install a newer linux system. Anyway, thank Irithori very much.

  6. #6
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,392
    There are subtle differences in the library/application versions and features from one distribution to the next.
    It would be beneficial to know, on which distribution this software was built and then install that OS.
    You must always face the curtain with a bow.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •