Find the answer to your Linux question:
Results 1 to 4 of 4
Good morning, I recently installed Fedora 3 under Microsoft Virtual PC 2004. It installed fine, however, I believe I made a mistake during setup. I selected my actual monitor (ViewSonic ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Location
    Upstate, NY USA
    Posts
    2

    Monitor Resolution screwed up


    Good morning,

    I recently installed Fedora 3 under Microsoft Virtual PC 2004. It installed fine, however, I believe I made a mistake during setup. I selected my actual monitor (ViewSonic G220FB) rather than leaving it alone as a generic monitor.

    Now, when I boot up the virtual machine even though the resolution is set to 800x600 in Linux, the resolution is 1600x600 and the screen looks like one from the Amiga days when you would try to run something in a Pal resolution on an NTSC monitor with vertical lines all over. Even with that I can barely make out what is on the screen so I went into the system display settings and attempted to change the monitor to generic crt. However, whenever I move to a selection outside of a ViewSonic monitor the Ok button becomes disabled.

    My question is, how can I update the monitor for this installation? It will be awfully difficult to successfully edit xf86config because of the readability problems on the screen.

    Any help is greatly appreciated!

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    start with this
    (to get to lower resolution)
    CTRL-ALT-NUM-

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    otherwise go the fun way shut down X-Server CTRL-ALT-BACKSPACE
    that will get you to terminal
    in there go into folder

    /etc/X11
    in there you should have a file called XF86Config
    as root,
    type vi XF86Config,
    go to the line where you setup your resolution, and change it there.

    after, type :wq (write / quit)
    and startx
    that will fix things up
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Location
    Upstate, NY USA
    Posts
    2
    I tried to exit from the GUI and it didn't work.. went to a black screen of smaller resolution and then back to the graphical login screen.

    I also tried resetting and booting from the rescue disk. From there when I went to /etc/X11 there was no config file... any thoughts?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2004
    Posts
    88
    if you could bring the linux box to init 3, you could run the command system-config-display --reconfig

    this will start the xconfiguration with no settings that are currently set oh, xconfiguration is now in /etc/X11/xorg.conf

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •