Find the answer to your Linux question:
Results 1 to 4 of 4
when I try to connect via PuTTY from a windows machine I get " PuTTY Fatal error connection timed out. I try to do so via a router redirecting IPadr:86 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2011
    Location
    In the island of Streymoy in the North Atlantic Ocean
    Posts
    2

    Connection timed out when trying to connect to Linux via PuTTY


    when I try to connect via PuTTY from a windows machine I get " PuTTY Fatal error connection timed out. I try to do so via a router redirecting IPadr:86 to local adr:22 on the Linux machine.

    I seems not to be a routing issue since the router is setup to redirect apparently correctly.

    Well I have stopped iptables and selinux is disabled. The sshd deamon is running. I can logon with ssh locally "ssh webcamATlocal adr" Any Ideas to how I can solve this puzzle?

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,558
    Are you trying to use putty to create an ssh connection, or a telnet connection? Also, you may have the port misconfigured. You don't specify what your putty connection options may be set to.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Jul 2011
    Location
    In the island of Streymoy in the North Atlantic Ocean
    Posts
    2

    more info about My PuTTY settings

    I am trying to create a ssh connection.

    My PuTTY connection options are :
    keepalives = 0
    Nagle's algorrithm = disabled
    Internet protocol version = auto

    Data:
    terminal-type string =xterm
    terminal speeds =38400/38400

    Proxy:
    =None

    Telnet
    = BSD (commonplace)
    = Return key sends Telnet New Line instead of (hat)M (underscored M)

    Rlogin
    =blank

    SSH
    -Kex
    Diffie-Hellman group exchange
    Diffie-Hellman group 14
    Diffie-Hellman group 1
    -- warn below here --
    Max minutes before rekey ( 0 for no limit) = 60
    Max data before rekey ( 0 for no limiir) = 1G
    -Auth
    Atempth authentication using Pageant chosen
    Atempth "keyboard-interactive" auth (SSH-2) chosen
    -TTY
    Terminal modes = all auto
    mode = INTR
    Value = auto
    -X11
    MIT-Magic-Cookie-1 chosen
    -Tunnels
    Local and auto chosen
    -Bugs
    all auto
    Serial
    Serial line to connect to = COM1
    speed (baud) = 9600
    Data bits = 8
    Stop bit = 1
    parity = none
    Flow control = XON/XOFF

    The possible port misconfiguration, is that on Linux or the Router?

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,558
    Well, you are using the telnet, not ssh protcol, so you need to be sure your xinetd is configured properly to allow telnet connections. If you prefer to use ssh, then you need to change the putty configuration for that connection.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •