Find the answer to your Linux question:
Results 1 to 3 of 3
Hello, I'm trying to install linux on a Macbook Pro family 5,3. I've tried Ubuntu and Federo and can not get either install to begin with either distro. I've already ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2011
    Posts
    1

    Linux on Macbook Pro


    Hello,
    I'm trying to install linux on a Macbook Pro family 5,3. I've tried Ubuntu and Federo and can not get either install to begin with either distro.

    I've already made a partition using boot camp. I've also installed reFIT to be able to boot the install disks (per suggestion of the Ubuntu Mactel Support documentation.

    With Ubuntu 11.04 the disk will start loading, and I get the dark purple screen with the little icons at the bottom. After this screen I only get a black screen with a flashing command prompt that does not respond to typing. I've left it like this for twenty minutes with no changes.

    I've also tried installing Fedora 15. With Fedora I get a similar reaction but I can actually get a boot menu to come up in the fedora install disk.



    After selecting Verify and Boot I get the following error



    On the second try a similar error but with the extra lines in the beginning:



    I'm not the most experienced Linux user so I really do not know what the issue is. If there is another distro that may be better for my Macbook then I would appreciate the suggestion. I would really like to get Ubuntu or Fedora working, so if anyone knows how to at least get the install started your help would be greatly appreciated.

  2. #2
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Hello and Welcome!

    Have you tried the other boot options?
    From your images, it seems to be a video driver issue (nouveau). Perhaps you would have more luck with the Basic Video boot option.

    If you have issues with that, post the errors from that as well.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  3. #3
    Just Joined!
    Join Date
    Jun 2011
    Posts
    12
    From what you said earlier it looks like you had a EFI problem with your Ubuntu 11.04(Natty).
    I also had that problem sometime ago.

    This is how i solved it.

    Make a usb pendrive bootable with your 11.04 on it.
    Also make a bootable CD with the 11.04 on it.
    NB:They should be of the same bits
    ie. both 32 bit or both 64 bits

    Insert your usb drive and insert you CD too.
    Restart your Mac and EFI should prompt you to select what to boot.
    I suggest you select the USB.
    Be patient with it.
    And i'm sure you would see a screen you should be expecting for your installations to occur.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •