Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I upgraded my 32-bit version of Fedora running on an Intel Core 2 Duo system from version 14 to version 15, and I am now unable to boot into X ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2009
    Posts
    22

    No X Windows after upgrade


    I upgraded my 32-bit version of Fedora running on an Intel Core 2 Duo system from version 14 to version 15, and I am now unable to boot into X Windows.

    What can I do that will help diagnose and fix this problem?

  2. #2
    Just Joined!
    Join Date
    Jan 2011
    Location
    Fairfax, Virginia, USA
    Posts
    94
    Hi, the easiest thing to do is:
    1. Be root
    2. Change the runlevel in /etc/inittab from 5 (boot with X) to (boot with everything except X) in a fashion like this:
    Code:
    Before:
    id:5:initdefault:
    to:
    Code:
    After:
    id:3:initdefault:
    3. Reboot
    4. Then, when you reboot, you should observe a login prompt. Login and run this command on the command line:
    Code:
    [brian@bmicek ~]$ startx
    Report back on what you see in the terminal window. Also, you can look at /var/log/Xorg.0.log but I think this approach is easier.

  3. #3
    Just Joined!
    Join Date
    Jan 2011
    Location
    Fairfax, Virginia, USA
    Posts
    94
    I'm sorry but I forgot to mention the above stuff will not work as-is with ubuntu because they decided to stray from UNIX standards. With ubuntu, runlevels are more complicated

  4. $spacer_open
    $spacer_close
  5. #4
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,025
    Quote Originally Posted by tron_thomas View Post
    I upgraded my 32-bit version of Fedora running on an Intel Core 2 Duo system from version 14 to version 15, and I am now unable to boot into X Windows.

    What can I do that will help diagnose and fix this problem?
    Do you mean that you want your system to startup in graphical mode as a default?
    Or that you can't get a graphical login at all?

    If it's the first, look here: Change Default Runlevel - Fedora 15
    If it's the second, post any errors you get when trying to execute startx.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  6. #5
    Just Joined!
    Join Date
    Mar 2011
    Location
    NH
    Posts
    14

    Drivers

    As jayd512 said, we probably need to know exactly what you see when you boot.

    If you boot into a login prompt and you cannot start X by using the "startx" command, then more than likely your new kernel did not get updated with the correct video drivers. If that is the case, you need to install the drivers, either using yum or if you are using proprietary drivers from the vendor's Web site.

    One of my system has an NVidia card and I have had to do that a few times.

  7. #6
    Just Joined!
    Join Date
    Feb 2007
    Location
    Cobleskill, NY
    Posts
    51
    If you get the GRUB menu then the easier way, in my opinion, is to start runlevel 3 as follows:
    select the Fedora item then hit A to add/change kernel arguments and simply add the number 3 at the end. You'll need to add a space between it and the rest of the kernel line.

    Now Login and then try startx and see what you get. It will likely point to the Xorg log file for the actual errors.

    Do you have nVidia. AMD/ATI, or Intel?

  8. #7
    Just Joined!
    Join Date
    Mar 2009
    Posts
    22
    I discovered that I can log into the system with X Windows after all. Originally I was selecting the topmost option in my GRUB menu because I thought that was the latest version of the kernel, and that was I was supposed to be using.

    The top most option was Fedora (2.6.38-35.fc15-i686). However, recently I accidentally accepted the default item in the GRUB menu which was Fedora (2.6.38-35.fc15-i686.PAE) and that did boot into X Windows and put at a graphical log in prompt.

    There is still a big problem. After, I log into the system I get a black screen of death that says:

    Oh no! Something has gone wrong.

    A problem has occurred and the system can't recover.
    Please log out and try again.
    I tried logging out, only the same problem happened when I logged back in. I'm not sure what causing the problem. I don't know if it has anything to do with some of the program that start automatically when the session log in. For example I can see Thunderbird starting up and displaying my e-mail right before the problem happens.

    What can I do that will allow me to fix this problem so I can successfully log into the system?

  9. #8
    Just Joined!
    Join Date
    Mar 2009
    Posts
    22
    I'm composing this reply on the system right now. It turns out I can log into the system if I choose KDE as my desktop instead of Gnome. I would like to get Gnome working

    What do people know about the cause for this error when booting with Gnome?

  10. #9
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,025
    If you can login with KDE, then at least we know that your system is okay. Something must have went wrong with Gnome during your upgrade.

    You might just want to remove and reinstall Gnome.
    From a console, as root, execute:
    Code:
    yum -y groupremove "GNOME Desktop Environment"
    And then
    Code:
    yum -y groupinstall "GNOME Desktop Environment"
    Then try to login.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  11. #10
    Just Joined!
    Join Date
    Mar 2009
    Posts
    22
    It looks like Gnome is not completely hosed. I can choose to log in with Classic Gnome using Compiz and that works.

    I don't know if I should still follow the steps to reinstall Gnome.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •