Find the answer to your Linux question:
Results 1 to 1 of 1
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Question Huawei E583C not finding pin - heeelllppp (Fedora15 Gnome3)


    I am a total newbie to linux and my husband handed the connection prob with the modem to me. I have installed usb_modeswitch and your program - after I found the can't read font fix, I thought I was set. But first had a prob with it not detecting GSM so I did noprobe - now it flashes a small screen saying "Modem responded ERROR while checking for pin". Then next box is" Failed connection". We don't have a pin with our modem. ( Even if it gave me an option of putting it in). And the modem works fine on windows but my husbands main program is linux.


    TY in advance,

    Update - after reading more I created a sakis3g.log here is a copy -

    Second update - After scouring the Internet more I tried to run it with shorewall disabled. Same error. I am also starting with noprobe, nostorage, interactive, and zenity

    Hope this helps you more than it did me lol And TG for dos if I hadn't messed with it quite a bit I would have been at a total loss when hubby turned this over to me Smiley

    After spending 2 5hr stints on this I have learned heaps but not how to fix problem yet. I swear my husband better take me somewhere nice for dinner when I finish this! Grin

    Update - I have run and rechecked usb_modeswitch it is being seen as a modem as opposed to a mass storage device. So thats not the prob. ( time spent 1 5 hr stint and so far another 8 hrs). Shocked

    Update - After a total of 13 hrs today I am throwing my hands up in the air and hoping someone here can help me out of my linux hole! Sad

    Ok did one more thing - am totally unsure if the usbmodeswitch worked because of this line in the log -
    331 bInterfaceClass 8 Mass Storage

    This is what I did -

    To make it switch from the "storage" to "modem" mode you need the utility "usb_modeswitch".
    After that you "emerged"/installed it, edit the file "/etc/usb_modeswitch.conf"
    Check that you don't have already any other sections for "0x1446" (there weren't any as of now - if you already find such a section, that one might actually be better that the one I state).

    So, now that you know 1) your "vendor" ID, 2) your "product" ID and 3) have edited "/etc/usb_modeswitch.conf" you can try to switch to the modem mode:
    usb_modeswitch -v 0x12d1 -p 0x1446 -H -s 5 -c /etc/usb_modeswitch.conf


    if usb_modeswitch didn't work what do I do? When I ran it the first time and changed values it told me hopefully it was sucessfull or something like that.....heeeeeeeeeelp!!

    Update - day 3 - tried usb_modeswitch again and it says Mode switch most likely succeeded. Bye. but when I check the modem is still listed as mass storage device ARRRRRRRRRRRRG
    Last edited by Lovi; 07-20-2011 at 02:28 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts