Find the answer to your Linux question:
Results 1 to 3 of 3
I went to install Fedora 11 on a Dell that had XP on it, everything went as usual since I had installed this on an old Xeon server a couple ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2011
    Posts
    1

    No root access after Fedora 11 install


    I went to install Fedora 11 on a Dell that had XP on it, everything went as usual since I had installed this on an old Xeon server a couple years before with the same disks.

    Oddly, when I went to login as root with the password I'd chosen, I got the authorization failed error.

    I figured I'd just fatfingered something twice and set about starting over.

    Once again, everything went swimmingly, no problems. Reboot....same error.

    Now I'm getting a little irritated-I'm getting up there in years, but I'm no idiot.
    Format, install, cardinal sin on the password being so easy President Scroob can guess it...
    "Authorization Failed."

    The truly irritating thing about this is the fact that the install on the servers had no such issue. It's a standard install, nothing custom, 32-bit OS. I'm stumped here folks.

    Any ideas?

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,307
    I'm not sure why the password is not working, but try booting into runlevel 1. Once there, you can change the root password (without knowing the current password).

    To boot into runlevel 1:

    1. reboot
    2. at the Grub/bootloader prompt, hit the [Tab] key to interrupt the boot process
    3. Use the arrow key to highlight your desired kernel
    4. Press the [a] key to modify the kernel arguments
    5. add " 1" to the end of the arguments, then press [Enter]

    Linux will now boot into runlevel 1, which basically is like safe mode, where no networking, services, or GUI is started. You should be dropped to a shell after a few seconds. You a root. Go nuts.

    E.g., to change the password, try:
    Code:
    echo "mypassword"|passwd --stdin root
    hth

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    15
    by default,GUI for root is disabled for security reasons,u will be able to login in command prompt with the same root password.GUI is only for users.if u want use GUI for root,then change runlevel to 3 in inittab file(by default it will be 5) and reboot the system,then it will boot in in command prompt,login as root,then give startx command.thats all u can now use GUI for root.

    regards
    hemanth

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •