Find the answer to your Linux question:
Results 1 to 5 of 5
Hi there, I'm running Redhat Enterprise 6. It's a fresh install with the default gcc installed, which is 4.4.5. The problem is that I need gfortran 4.6 or later for ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2011
    Posts
    3

    problems getting gcc 4.6.1 going


    Hi there, I'm running Redhat Enterprise 6. It's a fresh install with the default gcc installed, which is 4.4.5.

    The problem is that I need gfortran 4.6 or later for the quad precision libraries and I've spent hours trying to both manually install a new copy of gcc by both downloading the 80 meg zip file and doing the 3 standard commands:
    ./configure
    make
    make install

    Which always fails out on make. And I've also tried numerous RPMs off of the rpm sites to try to install either all of gcc or just gfortran. But those always fail as well with dependency problems, and when I try to install the dependencies they have more dependencies and sometimes the versions of the dependencies aren't compatible with each other it seems.

    So, does anyone know a good RPM I could use to fully update gcc to 4.6.1? Or do you have some other advice on how to do this?

    Thanks!

  2. #2
    Just Joined!
    Join Date
    Aug 2011
    Posts
    3
    Sorry, this should be in the "application" forums I suppose. Feel free to move it.

  3. #3
    Just Joined!
    Join Date
    Jun 2011
    Location
    Belgium
    Posts
    84
    Under fedora15 (and I suppose also under RedHat 6) there is a package gcc-gfortran.
    If you install it with yum, it should resolve all your dependency problems (gcc, cpp, libgcc, ...).

    Code:
    $> yum install gcc-gfortran
    and just run
    Code:
    $> gfortran --help
    or
    Code:
    $> man gfortran

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2011
    Posts
    3
    Yep tried that.

    Package gcc-gfortran-4.4.5-6.el6.x86_64 already installed and latest version

    The problem is redhat only has 4.4.5-6. I need at least 4.6.0 for the quad-precision math. So I was trying to install it myself.

  6. #5
    Just Joined!
    Join Date
    Jun 2011
    Location
    Belgium
    Posts
    84
    Sorry, misunderstood!
    Could it be that 'Fedora 15' users have more recent packages than 'RedHat Enterprise 6'. If you install fedora15, you have latest version :
    Code:
    $> yum info gcc-gfortran
    Loaded plugins: presto, refresh-packagekit
    Installed Packages
    Name        : gcc-gfortran
    Arch        : i686
    Version     : 4.6.0
    Release     : 10.fc15
    Size        : 11 M
    Repo        : installed
    From repo   : updates
    Summary     : Fortran support
    URL         : http://gcc.gnu.org
    License     : GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and LGPLv2+ and BSD
    Description : The gcc-gfortran package provides support for compiling Fortran
                : programs with the GNU Compiler Collection.
    If you try to install the Fedora15 package, you will certainly have the same problems as with make.
    Suggestion: ask your question on Redhat forum.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •