Find the answer to your Linux question:
Results 1 to 6 of 6
Hi ,everyone I am new to linux world. I had built up two linux server , one FC15 ,and other is RHEL 6, these two machines are in the same ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2011
    Posts
    3

    Question vncviewer--unable connect to socket: No route to host (113)


    Hi ,everyone

    I am new to linux world.
    I had built up two linux server , one FC15 ,and other is RHEL 6, these two machines are in the same subnet.

    I can SSH to FC 15 with no problem ,but vncviewer ,i type the FC15's IP ,and they ,i got the error "vncviewer--unable connect to socket: No route to host (113)" ,why ?

    On FC15, i had enabled Remote Desktop , and created a VNC configuration file.

    Thanks

  2. #2
    Just Joined!
    Join Date
    Aug 2009
    Location
    Sheffield, UK
    Posts
    9
    Firewall? Try telneting to the VNC port on the FC15 box or nmap the FC15 box from the RHEL6 box and see if the port is open. If it's not, try checking out the iptables config on the RHEL6 box.

  3. #3
    Just Joined!
    Join Date
    Aug 2011
    Posts
    3

    Smile Thanks

    Quote Originally Posted by nilocj-d View Post
    Firewall? Try telneting to the VNC port on the FC15 box or nmap the FC15 box from the RHEL6 box and see if the port is open. If it's not, try checking out the iptables config on the RHEL6 box.
    i do a iptables -F ,and then problem resolved

    By the way ,another question. Don't know why vsftpd service can't start

    i do a "/etc/init.d/vsftpd start -->500 OOPS cannot read the config file: start

    but the vsftpd.conf file exist under /etc/vsftpd/ folder and i tired this
    "chkconfig --level 35 vsftpd on
    service vsftpd start"

    still fail to start the service

    How to resolve this problem

    thanks

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2009
    Location
    Sheffield, UK
    Posts
    9
    Word of warning - iptables -F flushes all rules. Depending on the default chain policies (which I'm assuming are set to accept as you can now connect), that could leave you boxes wide open.

    I use vsftpd myself, albeit on debian servers and I think the set up is slightly different in terms of config file locations etc...

    But - are you trying to start as root? Check permissions on the config file. Try copying vsftpd.conf to /etc/ (debian default - not sure about RH)

    You could try (as root)

    strace /etc/init.d/vsftpd start

    and look for information about the config file it is *trying* to load.

    C.

  6. #5
    Just Joined!
    Join Date
    Aug 2011
    Posts
    3

    Smile Resolved~

    Quote Originally Posted by nilocj-d View Post
    Word of warning - iptables -F flushes all rules. Depending on the default chain policies (which I'm assuming are set to accept as you can now connect), that could leave you boxes wide open.

    I use vsftpd myself, albeit on debian servers and I think the set up is slightly different in terms of config file locations etc...

    But - are you trying to start as root? Check permissions on the config file. Try copying vsftpd.conf to /etc/ (debian default - not sure about RH)

    You could try (as root)

    strace /etc/init.d/vsftpd start

    and look for information about the config file it is *trying* to load.

    C.
    Thanks for your information .. Because all these two machines are test purpose ,so i use the -F option in iptables

    And for the vsftpd service .. i resolved by enter the "/etc/init.d/" folder ,and run command "./vsftpd start "

    can anyone tell me why i should need to add the "./"

    Thanks

  7. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    re the OOPS error, are you sure you did not do /usr/sbin/vsftpd start? That's the only way I could replicate your error.

    as to why the "./", that just tells bash that the file you are running is in the current directory (/etc/init.d/). If the file were in your path (say in /bin), then you would not need the "./". But you should not have to start it that way, I think something else is wrong.

    Make sure your initscript is not a symlink:
    Code:
    ls -l /etc/init.d/vsftpd
    Confirm the state of your vsftp package:
    Code:
    rpm -qV vsftpd
    As a side not, you can enable the vsftp daemon to auto-start upon reboot, so that you don't have to manually run it:
    Code:
    chkconfig vsftpd on
    EDIT: Sorry, didn't see your comments about already trying chkconfig. Which box is this, the F15 or the RHEL6? What is the exact error that you get after 'service vsftpd start'?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •