Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I recently got a dedicated server for fairly cheap and it works pretty well, except for it being a webserver. I set everything up according to the tutorial here: howtoforge ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2010
    Posts
    10

    Server setup problems


    I recently got a dedicated server for fairly cheap and it works pretty well, except for it being a webserver. I set everything up according to the tutorial here:
    howtoforge .com/perfect-server-centos-5.6-x86_64-ispconfig-3-p3

    and it all went fairly well. However whenever I try to go to anything on the server, like phpmyadmin or webmail or ispconfig to check it all out, it doesn't work. The error that I get when I try to go to them is as if the DNS wasn't pointed to the domain, however I'm accessing it from the IP address. In Chrome the error is "Error 118 (net::ERR_CONNECTION_TIMED_OUT): The operation timed out."

    Not quite sure what else to put in here as all the services are running fine and don't have any errors. FTP also gives the same error when trying to connect. Not quite sure exactly why it isn't working but any help would be appreciated.

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    By "go to anything", do you mean in a browser?

    Are you just trying to access services (http, ftp, etc.) locally, i.e., on the same box? If not, is the ip address in your network, or do you need a route to it?

    I assume your network interface is up, and is physically connected.

    Can you ping the ip address? Can you describe a simplified network layout, so that we can better help diagnose your problem?

  3. #3
    Just Joined!
    Join Date
    Jun 2011
    Location
    Belgium
    Posts
    84
    Can you access the webserver with 'http://localhost/' instead of your IP address? If you can, do you have your IP address in /etc/hosts?

  4. #4
    Just Joined!
    Join Date
    Aug 2011
    Posts
    36
    Do you have a firewall on your dedicated server? Most probably it is blocking access to those ports
    You can check by running:
    iptables-save

    Try disabling it:
    /etc/init.d/iptables stop

  5. #5
    Just Joined!
    Join Date
    Dec 2010
    Posts
    10
    All good suggestions. Sorry for the lateness of the reply, I've had to move to a new host as the old one was upping prices by more than double what they were. I have a new host, and I'm following the same tutorial, however this time I have a new problem. It's right at the bind-chroot install and set up. I've followed it exactly however I keep getting this error when I try and start it:

    Code:
    [root@ast ~]# /etc/init.d/named start
    Starting named: 
    Error in named configuration:
    /var/named/chroot/var/named/named.local:1: unknown option '$TTL'
    /var/named/chroot/var/named/named.local:3: unknown option 'Serial'
    /var/named/chroot/var/named/named.local:4: unknown option 'Refresh'
    /var/named/chroot/var/named/named.local:5: unknown option 'Retry'
    /var/named/chroot/var/named/named.local:6: unknown option 'Expire'
    /var/named/chroot/var/named/named.local:7: unknown option 'Minimum'
    /etc/named.conf:30: unexpected token near end of file
                                                               [FAILED]
    The contents of that file are this:

    Code:
    $TTL    86400
    @       IN      SOA     localhost. root.localhost.  (
                                          1997022700 ; Serial
                                          28800      ; Refresh
                                          14400      ; Retry
                                          3600000    ; Expire
                                          86400 )    ; Minimum
            IN      NS      localhost.
    1       IN      PTR     localhost.
    Any ideas what could be going on? This time I can access phpmyadmin through ip/phpmyadmin so something is at least doing something right.

  6. #6
    Just Joined!
    Join Date
    Aug 2011
    Posts
    36
    Can you please post the contents of /etc/named.conf?

    There's something wrong with that file

  7. #7
    Just Joined!
    Join Date
    Dec 2010
    Posts
    10
    There's no actual /etc/named.conf, however there is one in /var/named/chroot/etc/ and I'm guessing it's there because it's bind-chroot, but I haven't dealt with bind-chroot really so I don't know if that's normal or not but here's the contents of it:

    Code:
    //
    // named.conf
    //
    // Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
    // server as a caching only nameserver (as a localhost DNS resolver only).
    //
    // See /usr/share/doc/bind*/sample/ for example named configuration files.
    //
    options {
            listen-on port 53 { any; };
            listen-on-v6 port 53 { any; };
            directory       "/var/named/chroot/var/named";
            dump-file       "/var/named/chroot/var/named/data/cache_dump.db";
            statistics-file "/var/named/chroot/var/named/data/named_stats.txt";
            memstatistics-file "/var/named/chroot/var/named/data/named_mem_stats.txt";
            allow-query     { any; };
            recursion yes;
    };
    logging {
            channel default_debug {
                    file "data/named.run";
                    severity dynamic;
            };
    };
    zone "." IN {
            type hint;
            file "named.root";
    };
    include "/var/named/chroot/var/named/named.local";

  8. #8
    Just Joined!
    Join Date
    Aug 2011
    Posts
    36
    I can see the problem. You can't just include a zone file.

    You need to change the last line to:
    zone "localhost" {
    type master;
    file "/var/named/chroot/var/named/named.local";
    };

  9. #9
    Just Joined!
    Join Date
    Dec 2010
    Posts
    10
    That worked perfectly thanks! Now I just have one (hopefully final) problem. After running yum install pure-ftpd it won't start:

    Code:
    [root@ast web]# chkconfig --levels 235 pure-ftpd on
    [root@ast web]# /etc/init.d/pure-ftpd start
    Starting pure-ftpd:                                        [FAILED]
    Any ideas? Not entirely sure what's going on and this is the error in /var/log/messages

    Aug 11 14:16:59 ast pure-ftpd: (?@?) [ERROR] Unable to switch capabilities : Operation not permitted

  10. #10
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Maybe you need to load the kernel capabilities module?
    Code:
    modprobe capability
    If that becomes a head-ache, any reason you can't use vsftpd instead?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •