Find the answer to your Linux question:
Results 1 to 9 of 9
This is the entry when I tail /var/log/secure when I ssh for user "nightly"... Code: Aug 4 03:19:48 itanium2 sshd[10791]: Illegal user nightly from ::ffff:10.91.220.35 Aug 4 03:20:10 itanium2 sshd[10791]: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! kirtikjr's Avatar
    Join Date
    Apr 2007
    Posts
    29

    Cant ssh for a user


    This is the entry when I tail /var/log/secure when I ssh for user "nightly"...


    Code:
    Aug  4 03:19:48 itanium2 sshd[10791]: Illegal user nightly from ::ffff:10.91.220.35
    
    Aug  4 03:20:10 itanium2 sshd[10791]: Failed password for illegal user nightly from ::ffff:10.91.220.35 port 32862 ssh2

    What could be the reason, plz suggest.

  2. #2
    Just Joined! kirtikjr's Avatar
    Join Date
    Apr 2007
    Posts
    29
    and password is correct, works when I telnet, just ssh fails.

  3. #3
    Just Joined! kirtikjr's Avatar
    Join Date
    Apr 2007
    Posts
    29
    there is a local user for the host with which I can ssh to the system but not with nightly. nightly is not in /etc/passwd

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,318
    What authentication mechanism is "nightly" using to authenticate via telnet?

  5. #5
    Just Joined! kirtikjr's Avatar
    Join Date
    Apr 2007
    Posts
    29
    I guess it uses LDAP or NIS

  6. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,318
    On the server, in /etc/ssh/sshd_config, is a list of users listed in AllowUsers?

    If LDAP/NIS, maybe there is client-side configuration that needs to be done? Google for something like "Failed password for illegal user" + NIS or LDAP

  7. #7
    Just Joined! kirtikjr's Avatar
    Join Date
    Apr 2007
    Posts
    29
    there is nothing listed in AllowUsers. Let me try to see somewhere else. thanks

  8. #8
    Just Joined! kirtikjr's Avatar
    Join Date
    Apr 2007
    Posts
    29
    the IP settings of the present host was changed.
    So the keys got messy.
    I disabled the PubkeyAuthentication option in /etc/ssh/sshd_config
    Now I can login, but i need to regenrate the keys

  9. #9
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,318
    ah. you can use ssh-keygen for that. and try ssh-copy-id to properly and safely copy the SSH keys to your remote host.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •